Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

A4899 Troubles above 1kHz

Hi,

I am currently attempting to use a A4899 to drive a small stepper motor, link below. I have the driver and motor hooked up per the picture on the Pololu website at the bottom of the product page. The DIR pin is connected to logic GND. Vmot is 12V from a power supply, logic voltage is 5V. I have reset and sleep shorted together. I am driving the STEP pin with a square wave from a waveform generator at the moment. I am not using the MS inputs.

The issue I am having: While driving the STEP pin with a square wave, 0-4.5V, the motor works pretty well. However at any frequency above 1kHz the motor wont spin, current drops to close to zero. It sort of just buzzes. Any ideas?

I am missing the cap b/t Vmot and GND. I didn’t have the correct value on hand. Could this be affecting anything?

Thank you for your help!

https://www.amazon.com/Adafruit-PID-324-Stepper-motor/dp/B01N30ISYC/ref=sr_1_1?dchild=1&keywords=B01N30ISYC&qid=1600174900&sr=8-1

Hello.

From your description, it sounds like you might be reaching the step rate limit of your current setup. There are a lot of factors that go into how quickly you can step a stepper motor, including operating voltage, current limit, microstepping mode, acceleration ramping, the load on the motor shaft, and more. What do you have the VREF voltage on the A4988 carrier set to?

I do not see any datasheet in the listing you linked to, but if you can find one for your motor, they commonly have a pull out torque curve you can use to get an idea of what kind of step rates are achievable. The listing you linked to does mention 50 RPM, and at 1000 steps per second, in full-step mode, you are well beyond that at 300 RPM. You can find some general suggestions for getting a higher step rate in this forum post by Ben.

Brandon

Brandon,

Thank you for the quick response, that makes complete sense, I was just worried I had done something wrong. This speed is fine for me.

Thanks again,
Tyler

1 Like