4WD Crawler with 18V7 Controllers not working

I am building a 4WD RC crawler from scratch. I am using 12V DC motors and 18V7 controller boards. I have connected everything as per normal requirements. From the RC receiver I am using two Y Splitter cables.
My problem is the left wheels are turning when I function the throttle. The right wheels do not turn.
I have checked all cabling, etc.
I did notice the left side controller board only shows the orange LED turned on, The RED LED is not illuminated. The right side controller board has the RED LED on continuously when powered up and the orange LED is flashing.
Left and right sides are wired the same using the same battery. Both boards were calibrated using the wizard.
Can anybody tell me what the LED lights mean and why is the Red light illuminated on the right side but I don’t have an output from the controller board? I did measure both sides with a voltmeter.

Thank you for your time.

UPDATE - I setup my spare controller using wizard. I installed it into the RC circuit. Now all the wheels are turning properly. The 18V7 controller board was faulty. This is a new board that was just taken out of the package.


I am sorry your are having problems with your Simple Motor Controller. We test each of our boards, so we are reasonable sure they worked at one time, so we would like to do some troubleshooting to see if there might be something else in the system that is involved.

The red LED is an indication that the Simple Motor Controller has an error. You can read the error in the Simple Motor Control Center software under the “Status” tab. Can you try connecting your controller to USB and checking for errors? Also, can you post some pictures of both sides of the suspect SMC?


Hello Derril,
Please see attached pics of the status page and both sides of the board.
The pic of the status page is with the board plugged into the USB with nothing else connected.

I don’t believe it is a board fault but I can’t determine why the error light is present.


Thanks for posting the pictures, I do not see anything obviously wrong with the board and the three errors you are getting (safestart violation, required channel invalid, and low VIN) all make sense since the controller was not connected to any input signal or voltage. Can you put the SMC back in your setup so it gives the same error as before and post a screenshot of the Simple Motor Control Center showing the errors?