36v9 motor driver issue

Hi, I´m developing a project using 2 wiper motors and 2 36v9 motor drivers, but I can not do it works properly.

I´m controlling the motor driver with LIFA (Labview interface for arduino) and an Arduino mega 2560, when I try drive the motor I put HIGH in ‘dir’ pin and a PWM signal on ‘PWM’ pin, the motor runs but not properly. I mean, if I connect the motor to PS with 12 V, the motor runs faster than if I connect it to the driver. It seems like the driver has power losses. In the other hand, if I put LOW in ‘dir’ pin, the motor turns in the other direction, but slower than before. I tried changing the PWM frequency, but the problem persist.

I´m using a 12v 12,5A power supply, connected to V+ and GND pins, and GND connected with GND from arduino, the FF1 and FF2 pins are at LOW status.

In this situation, I have not got enought torque for my project. I´m really sure that those motors are adequate. I seen on the web those motors used on Electric bikes projects, and I think my project requires less torque than that bikes.

I´m really despaired with this, I need help.

Thank you very much, and, I apologize for my english.

Hope you can help me soon. See you


I am sorry you are having problems using your high-power motor driver. How does the speed of the motor change when varying the duty cycle. Could you try driving the PWM pin on the motor driver HIGH and see if the motor drives at full speed? If it does not, could you tell us more about your setup? Do you have any additional information about the motor (do you have a link to its datasheet)? Could you also post pictures of your setup?

- Jeremy

Hi Jeremy, thanks for your reply.

I just tried putting high on PWM input and the motor works better, now turns full speed i both directions. I guess the problem is how arduino generates the PWM signal. I will try to handle the motor with servo libraries, I remember that behavior on servos when I made a minisumo robot.

Unfortunately, one of my 36v9 died in this process. :frowning:

thanks for all, I will post here my process.

I suspect your PWM signal is not being generated correctly. If you have access to an oscilloscope, you might try verifying that the Arduino can generate PWM signals through the whole duty cycle range.

How did you determine the driver is dead? If you would like to troubleshoot what may have caused it to break, could you tell me about how you were using it when it broke? Could you also post pictures of your setup?

By the way, I do not expect servo libraries to work well for generating PWM signals for that driver.

- Jeremy

It doesn´t work.

There are no reason for this behavior, one direction turns ok other direction turns badly, with the same PWM signal. I think maybe the problem is in the dir pin. I see a perfect PWM signal on osciloscope, so Arduino generates the signal correctly.

In the other hand, the current measured in PS output is under 1A with 100% PWM signal, when I put 12V dc directly to the motor the current without load is arround 3A.

I am thinking buy other type of driver, but I have no time for it, my company needs this project working soon.

Thanks for all, I let you know my progress.

Could you try swapping the motor leads around and see if the motor still has a problem turning in the same direction or if the problematic direction switches? Could you also post pictures of your setup that show all your connections?

- Jeremy

Hi Jeremy,

Thanks for your response.

I will try a couple of things, first I´m looking for other DC motor to compare behavior, doing this I could know if the problem are in my wiper motors, second I will try all the configurations of the driver and will capture all the waveform at the output of the driver, take pictures and post here.

Could I find the schematic of this drivers to study the circuit? Is the schematics open? it is so difficult solve this when the driver is a black box for me.

Thanks for all.


We do not release the schematic for our High-Power Motor Driver 36v9. We try to make all the information we think our customers would need to use them available on their product pages. Is there a particular specification that you need that is not on the High-Power Motor Driver 36v9 product page?


Hi BrandonM,

Iasked for the schematic because I wanted more information about the driver, I´m still testing the driver and I think I found where is the problem. Can you tell what is the meaning of FLOAT in dir pin?, I think this pin is not compatible with ‘1’ logic given by Arduino. I can´t give you a picture of my setup, I try to explain it: I connect PWM to pin ‘2’ of Arduino (pin PWM capable), dir to pin 30 (digital IO), and reset to pin 32 and HIGH level. Ground from arduino and ground from driver is connected too. A Power Supply and the motor are connected to the driver.

When I measure waveform in dir pin and connect probe gnd to gnd and probe to dir pin, the motor runs correctly. This pin in arduino is driven by internal pull-up resistor, so I guess the problem is a load effect on dir pin of the driver or something like that.

However, one of the 2 drivers I bought is dead, so I need buy another driver and I´m looking for other driver because I need it this week or next.

Thanks for all.

A floating pin is a pin that is not being driven to any defined logic level. Since the DIR pin is floating, it needs to be driven high or low to determine what direction the motor will spin. This can be done from an Arduino pin configured as a digital output.

Also, if the problem goes away when you make connections with the probes of your multimeter, it sounds like there might be a connection or ground problem. Are your header pins soldered in properly? Could you make sure that your ground connection is making a solid electrical connection?

By the way, you mentioned you have a broken driver. Do you know how that board got damaged?



I think the board was damaged while testing, I guess there was a short, I´m not sure.

I tested all connections with polimeter and resoldered some connections, but the problem persist. I tested put 5v from external supply directly to dir pin and works correctly. Also tried putting a pull-up resistor to drive the pin. Today will test other kind of possible solutions, next time I will test with another Arduino Mega.

thanks for all.

Since the board works when you apply a 5V input from a different source, it sounds like your Arduino is not working correctly, there is a connection problem between your Arduino and motor driver, or there is a problem with your Arduino code (such as controlling the wrong pin). If switching out the Arduino Mega does not fix the problem, I suggest double checking your connections and Arduino sketch.


I´m using Arduino with LIFA (Labview interface for Arduino) programming is not the problem, I finally think that the problem is on PWM signal, I think LIFA use the same timer than PWM or something like this. In the oscilloscope the waveform is absolutely normal. At this moment need have some progress on the project and I´m working on other things. I will return to work on the motors and will try solve it.

best regards.