36V4 with Arduino Trouble

hello Pololu team ,
I have a problem with my 36v4 driver !
I had connected the driver with my Arduino and it worked well, but today the motor does not work anymore ! Do you have an idea why the code stepping basic program does not work anymore on my Arduino


What happens when you try to run the basic stepping example now; are there any signs of life from your setup either from just looking at it or from using an oscilloscope to see what is going on? Can you post some information about the motor and power supply you are using, like data sheets for them or links to where you got them?

- Patrick

If there is voltage being applied across the driver outputs but your stepper motor is not energizing and no current is going through it, then that suggests your stepper motor has been damaged. Can you post a datasheet for your stepper motor and measure the coil resistance across each phase? Is it possible the motor was ever disconnected from the driver while it was energized, or could you have forgotten to configure the current limit in the new program you uploaded before things stopped working?

- Patrick

i iuse this Longruner Stepper Motor:
Electrical Specification:

  • Manufacturer Part Number: 17HD48002H-22B
  • Motor Type: Bipolar Stepper
  • Step Angle: 1.8 deg.
  • Holding Torque: 0.59N·m(84oz.in)
  • Rated Current/phase: 1.7A
  • Phase Resistance: 1.8ohms
  • Inductance: 3.8 mH ±20% (1KHz)

Physical Specification:

  • Motor Body Length: 48mm
  • Motor Full Length: 70mm
  • Shaft Diameter: 5mm
  • Shaft Length: 20mm
  • D-cut Length: 15mm
  • Number of Leads: 4
  • Lead Length: 1m with connector
  • Motor Weight: 380g
  • 17 Mounting Bracket - 90 degrees
  • Mounting Holes: 31mm center-to-center
  • Max Collar Diameter: 22mm

how do i check if my driver is working and not damaged?
thanks for your quick reply Patrick
I appreciate your support

We do not have some specific diagnostic procedure you can follow to confirm your driver is working beyond wiring it according to one of the minimal wiring diagrams on the product page and testing it. As I explained in my last post, if you are seeing voltage being applied across the driver’s outputs and nothing is happening (as you indicated in the post you withdrew), then that suggests your stepper motor has been damaged somehow. The voltage across the coils should at least be energizing the motor.

Have you checked your motor’s coil resistance across each phase as I suggested?

- Patrick

I checked the resistance of the motor, it works, I bought a new driver but it still doesn’t work!
the driver does not provide any information about the motor and the motor is functional
The driver receives power but it doesn’t work like the Basic Stepping example

Just to confirm, it sounds like you tested your motor with two different drivers and it is not showing any signs of life with either of them, is that correct? Can you also confirm whether or not each driver is applying voltages across the driver outputs?

Your connection diagram looks okay, though the example programs in our library definitely could not be working without some modifications. Can you post the exact program you are uploading to your Arduino so that I can check that the modifications are appropriate for your connections?

- Patrick