21v3 g2 doesn't recognized by PC

For some reason my computer stopped identifying my 21v3 G2 motor when I connecting it using USB. Up until a few days ago everything worked great but today I tried connecting the motor to the computer and the software couldn’t find it (the “connected to” list was empty). Once I connect the USB a brief green light starts blinking once a second and that’s it.
I tried different computers and USB cables but nothing helped…


Just to make sure your cables and ports are okay, can you check if they work with another device?

If your cables and ports are okay, the “Installing Windows drivers and software”, “Installing Linux software”, and “Installing macOS software” sections of the Jrk G2 user’s guide each have a USB troubleshooting guide; can you go through the those instructions from the appropriate section for your operating system and let me know what happens?

If nothing there resolves the issue, please let me know what operating system you are using, and if you are using Windows, please post a screenshot of the Windows Device Manager while the Jrk is connected. Please make sure to have the “Other devices”, “Ports (COM & LPT)”, and “Universal Serial Bus devices” lists expanded.

- Patrick