#2134 Low-Voltage Stepper Driver Not working

I am not getting anything.

The step voltage is a steady 225 mV, seems strange I am running the Pololu stepper code
which should do 50 steps and then reverse.

I know very little about stepper motors, I have had them working with other drivers.


Hello, Ralph.

Can you post a link to your stepper motors specifications? What are you using to supply power? What do you have the VREF voltage set to on your DRV8834? Also, can you post some pictures of your setup that show all of your connections?


I am using desktop Power Supplies not USB.


I tried .5 v voltage reference but then saw the stepper spec says .6a so
not sure what I should have for reference voltage.
I have tried different mV but never works.

The green led is on the Step wire strip. On other steppers the led would
light on each step.
It does not light while connected to the DRV8834 but if I connect the step
wire directly to the led without the DRV8834 it flashes.

I have other steppers to try.

Thanks for the reply.

From your pictures it is clear that you have the boards orientation wrong in relation to the pins you are connecting to. It looks like you have your power input connected to the STEP and DIR pins and your input signals from your Arduino connected to the VIN and GND pins. All of the other pins are similarly connected incorrectly. You can try fixing your connections and see if the board works; however, please note that connecting your input power to the STEP and DIR pins might have damaged the DRV8834. If the board is damaged, you can send your order information and a reference this forum thread to support@pololu.com, and we will see what we can do to help you out.


WOW, thanks I have the DRV8834 reversed, thank you.


Well Derril rescued me on my last question so thought I’d try again.

I am getting a pulse at the motor but no motion, the motor is not turning.

This is a 9 volt .6 amp stepper I have Vref at .4 volt.


New Picture of setup.

I have my multimeter + on a screwdriver on the potentiometer.

Hard to get lower that .4v just a slight touch and it is in mV.

Hello, Ralph.

I moved your post to your previous thread since it seems like you are still using the same setup and driver.

Your current limit is set a little too high for a 600mA current per phase rating; you should set your VREF voltage to 0.3V. How are you measuring the output of the DRV8834 carrier? Also, can you post updated pictures of your setup?

EDIT: I posted this on the previuous thread so this post in out of order and should be before Ralph’s last post.


Thank you for posting the updated picture. Those connections seem fine. Your previous post made it sound like you might have been measuring the output of the DRV8834 carrier at the motor output pins and not just the VREF voltage. If you are getting good signals at the DIR and STEP pins and the driver is not stepping, it might be damaged from your earlier setup as I mentioned previously.

Can you try removing your motor and using your meter to measure one of the output pins and see if you are getting any voltage on it when you run the example sketch in the “Setting the Current Limit on Pololu Stepper Motor Driver Carriers” blog post?


I am using a new DRV8834 and new stepper motor. Same results.
Here is a video the first half I am showing Vref then I switch to measuring motor output pin voltage.
At times I am seeing >8 volts at the motor pin.

The noise you hear is the motor pulsing but not rotating.

I noticed that your soldering shows signs of improper wetting; can you try touching up your soldering to see if that helps? Can you also test your connection wires to be sure each of them has proper continuity? Also, can you tell me the voltage and current ratings of your power supply?

By the way, your video is in a format that only plays in Live Movie Maker, can you repost the video in a more standard format? You might consider posting your video on YouTube and post a link to it here.


Thanks for the reply.
Powering the stepper I have a 30volt 10amp adjustable power supply:

Powering the Arduino I have portable computer brick power supply.

Note .65mA does that look right? Actually it varies 82 mA -45mA.

The current reading on your power supply is not a good indicator of the actual current to your stepper motor coils. If you want to measure the DRV8834 output current you should connect a multimeter in line with one of your stepper motors coils. However, your power supply should be fine as long as you do not have the supply’s current limited set to below about an amp. Did you touch up your soldering and test the connection wires? Can you post updated pictures of your soldering?


Yes, trying to get decent photo.

Also hardwired most everything instead of using jumper wire.

1st time I turned on the stepper it actually rotated, very slowly and
weakly, but then stopped and just makes a noise with each step pulse.


Well it is working!!

I have M0 and M1 to GRN (Full Step) and Enable to GRN.


Thanks for letting us know you got it working.