18v25 setup for unidirectional / analog control

Very pleased with the controller. However, I will be using it to drive a 12v DC fan and don’t want the fan to run in reverse. I am controlling this with a pot connected to analog 1. I used the easy setup, centered the pot for neutral, then max/min, and the output voltage does what I expect (-12 v to +12) However, I need the output to go from 0 to +12, no negative.

I tried a search of the forum, but don’t see any relevant posts. Sorry if this is already explained in another post.

I expect that there is probably a calibration trick that will do this.

Thanks in advance. Chris

I still hope there is a simple calibration trick for this, but I think I have figured out a work-around. I have not tried it, but don’t see why it won’t work.

It goes like this: instead of just the pot, add a second resistor of equal value in series to the pot. (e.g. if pot is 5K, add a 5K resister in series so the total is 10k). Connect the + to the pot end of the series, and the - to the other end. Signal terminal is on the variable leg. Dial the pot so it is minimum resistance. Start the quick easy calibration. (With pot all the way down, this will be the neutral or mid-position). Take the midpoint reading. When asked to move the pot to minimum, leave it at minimum but also connect the negative to the signal terminal, take the minimum reading. Remove the connection between negative and signal. When asked to move the pot to maximum, turn it to max and take the max reading. Calibration should be done. Leave the resister and pot connected in series. I think that when calibrated this way, you will have the ability to control from 0 to +12, and it will never go negative.

I welcome any other thoughts or suggestions.


Hello, Chris.

There are two settings that can accomplish this. The “Neutral minimum” in the “Input Settings” tab can be set the same as the “Minimum setting” so that no portion of the potentiometer input is mapped to settings that would cause the motor to spin in reverse. You can also change the motor settings so the motor will not turn in reverse, even if the input values would normally indicate that it should do so. To do this, check the “Asymmetric” box in the “Motor Settings” tab and set the “Max. speed” in the “Reverse” column to zero.

Please note that if you only adjust the motor settings without adjusting the input settings, the lower half of the potentiometer range will not drive the motor. I recommend changing both settings to utilize the entire potentiometer range and to make sure the motor does not run in reverse.


Thanks. That sounds like what I was looking for. I will try that. If you don’t hear any more from me, it worked.