18v15 Simple High Power Motor Controller Not Being Detected

Have a 18v15 High Power Simple Motor Controller not being detected by raspberry pi 2 through a usb connection. Have a green light on the motor controller but SmcCmd -l says 0 Simple Motor Controllers found. Have tried with motor and batteries connected but have assumed they dont need to be for detection through usb. Thank you


I am sorry to hear you are having trouble with your Simple Motor Controller. Does the green light come on solid, or does it blink steadily when plugged into the USB port? The motor and batteries do not need to be connected for the controller to be recognized by the computer. Could you try using a different USB cable?

Could you run the “lsusb” command at the command prompt on the Raspberry Pi with your Simple Motor Controller plugged in and post the results here? The output should have a line for a device with an ID that begins with “1ffb”.

It would also be helpful to look at the messages from the kernel ring buffer using the ‘dmesg’ command. Can you run the following command immediately after plugging in the controller?

Has your Simple Motor Controller worked on any computer in the past?