1207 Stepper and MP6500 driver problem

I have trouble with a 1207 motor (7.4V, .28A) and a MP6500 driver (5-35V power supply). When I power the driver with 18V, the motor runs terribly. I suspect it’s because the motor is rated for .28A, but the lowest I can set the current limit on my MP6500 is a bit north of .31A. (The minimum I can set Vref is .089V, and the constant for the driver is 3.5 A/V, so 3.5 x .089V = .31A) I suspect this is saturating the coils and causing problems. I have tried two different MP6500 drivers, and both have the same limitation.
I have found that if I power the driver with 6V, the motor runs much, much better. I suspect this is because the lower voltage also limits the max current the driver can deliver. However, I don’t think this is a satisfactory way to limit current. Particularly since I no longer know what the current is, and I may be sacrificing some motor torque.
I’ve considered trying a different driver, but all of the specs just list the maximum current output. None of them seem to say what the minimum adjustable output current is.
Is my diagnosis correct? Is there something I’m missing?


Can you post some pictures of your setup and tell us what step mode you are testing your driver in? Also, 18V down to 6V is a pretty big jump; can you try some intermediate voltages?

When supplying a voltage below a stepper motor’s rated voltage, you can calculate the maximum current using the coil resistance and Ohm’s law (V=IR). Powering your motor from a source lower than its rated voltage (and therefore limiting how much current it can draw) will reduce the maximum mechanical power (torque and speed) it can generate.

- Patrick

There’s nothing like having someone looking over your shoulder to help you straighten things out.
I was preparing a response for you, including some photos and videos. In the process, I took a closer look at my 18V power supply, and found that it was only rated for 80mA, which is woefully inadequate for a 280mA motor.
I cannibalized another 12V supply that I had at home, which has a 2.5A capacity, and the motor runs fine with it.
It seems that my problem was user carelessness.
I will consider my problem solved.
Thanks for steering me toward a solution.

1 Like

I am glad to hear you figured out the problem; thanks for letting us know!

- Patrick