Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Zumo32U4 Not Detected By Computer but Powers Up via USB

Hello,

It has been couple of days that I am trying to get my newly installed Zumo32U4 detected (I do not mean recognized) by the Computer. Brief history of my issue is as follows:

1- Zumo works fine on batteries and every single demo installed at the factory runs flawlessly.
2 - Zumo is powered up and works fine on USB cable as well (When connected to Computer).
3 - But there is not even a sound or a change in the list of devices listed under Device Manager>Connection Points> COM or LPT
4- I have followed every single step instructed and recommended in the User Guide: My operating system is Windows 8.1 so I followed 5.1 of the User Guide to install the drivers ( 5.1 - Installing Windows Drivers
5- After installing the drivers and when I plug the robot into the USB drive, there is no action. (Interestingly it works, but computer takes no action)
6- I checked the USB cable it works fine with all other devices.
7- I changed the USB ports, the same problem.
8- I used a USB hub, same story.
9- I tried three other computers running on Windows 10 and Windows 7, no luck.
10- I followed the instructions under 9. Reviving an unresponsive Zumo 32U4 and 9.1. Reviving using the Arduino IDE nothing changed.
11- I searched the forums and saw similar issues but not the same. Because other users are seeking a solution to unrecognized device warning of the Windows Device Manager. I could not even come close to that point because when I plug the device in, there is no action on computer, but robot is powered up and the factory default demo is running.

Photo of the version that I have is below:

Please help me with this problem.

Hello.

If it were not for point #6 we would be fairly certain there is either a problem with your USB cable, or that it is a charging-only cable. Just to confirm, when you say your cable works fine with all other devices, did you test its ability to transfer data, not just charge or supply power? Do you have any other cables you can test just in case?

Also, can you inspect the USB connector on your Zumo for signs of damage?

- Patrick

Thank you very much!

It was all about the cable being charging-only cable.

My problem is solved.

Have a great one!

2 Likes