Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Zumo user button Pin 12

Hello,

I recently purchased a Zumo Robot for Arduino v1.2 (https://www.pololu.com/product/2510) and noticed that the user button near the power switch does not work. It is supposed to be connected to pin 12. I tried the pushbutton example from the Zumo library and there was no change in the pin 13 led when the button is pressed. I then tried the same code by just connecting pin 12 to ground with the jumper and was able to blink the led on pin 13. I’m not fully sure whether there is a problem with the button on the board or a soldering problem since I currently do not have a multimeter to check the contacts. Any help would be great. Thank you!

Hello.

Can you post some pictures of the malfunctioning button? Does your Zumo’s reset button work?

Also, just to make sure, are you sure you are pressing the button down all the way? If you are not sure, or if you think the button just might be stuck, you could try pushing the button with the point of a pen.

- Patrick

Hi Patrick,

Thanks for your reply. I have posted pictures of the button below. The Zumo reset button works fine. The User Button for Pin 12 does not do anything when pressed. It also is not stuck since the button moves when pressed. I also tried pushing the button with a pen but that did not have any change. If you need anymore information or images please let me know!

I do not see anything obviously wrong with your button. Please email us at support@pololu.com with your order information and a reference to this thread.

- Patrick