ZUMO Shield/Arduino stk500_getsync() compile error

After assembling my ZUMO, I was in the process of tweaking the motors so the ZUMO could run in a straight line. I worked with it for an hour or so adjusting timing on the motors and recompiling and testing. All of a sudden the Arduino complier started complaing with the following error message: “stk500_getsync(): not in sync: resp=0x30”. I went to the Arduino forums and tried
all the hints/tips to fix but none worked. When I remove the Arduino from the shield and
load the program, it loads without error. When I attach the Arduino to the Shield I get the
error. This pretty much points to the Shield being the culprit. Anyone experience the same
problem? If so, please share… the ZUMO/Arduino has poentital but it has to work first!! :confused:

It worked for a long time, right?
Are you using digital pins 0 and 1 for anything else?
Is there any solder bridge or debris contacting those pins anywhere on the shield or board?

Long time? After assembly, I was testing it by running a loop (straight for 2 seconds, backward for 2 seconds). The straight run tended to turn left slightly so I was tweaking the right motor
to run time to run a bit slower. Would run it in the loop again to test and almost had it
running straight when it started producing the error. I’m not using digital pins 0 or 1 in my code
and I don’t suspect the ZumoMotors include does either.

I’m leaning towards your suggestions (maybe a solder bridge) but there is nothing on the
bottom of the shield to short on (the plastic shield between the board and chasis prevent

I have disassembled the ZUMO chassis, checked for solder bridges (none found)
and reassembled but have not secured the ZUMO shield to the chassis with
the screws provided. The shield with piggy-back Arduino are just sitting
on the ZUMO chassis. In this configuration, I am able to load the sketch
without errors. There may be an issue when the ZUMO shield is secured
with the screws… maybe a trace or something happening if the shield
gets torqued (by the action of tightening the screws…).

Not sure what it may be. I will try to mount the shield/Arduino on stand-offs
from the chassis to see if the issue returns or has gone away.
This issue is identified and resolved with a workaround. I have ordered
a new shield from Pololu. Thanks for your quick response.

The solder blobs from the header connections, and some through-hole components, poke through the plastic shield; there are holes for them. It’s possible these are shorting out some pin. Try adding a washer between the chassis and the plastic spacer for more clearance, or putting some thin insulating tape on the batteries and motors that are below these holes.


Did you trim the header pins that are above the motors as described in the assembly instructions? If you didn’t trim them (or trim them enough), they can be shorted together through the metal motor case. Pins 0 and 1 are right above the motors, so this could be the explanation for your problem. Can you try trimming them more and potentially putting a piece of electrical tape over the motors to insulate them from the shield pins above?

- Ben

Yes, trimmed them AND put electrcal tape over each motor. But upon on
a visual inspection, I see three little dimples in the electrical tape on both
motors. So, I’ve trimmed the header pins on both side. It is possible that
the 0 and 1 pins were piercing the tape. Will add another layer of tape
and try to remove any sharp edges on the headers…

I’ve put spacers between the Shield and the chassis and it seems to be working
with no errors. I now believe since I found the dimples in the tape on the
motors and the error indicated a problem communicating with the Arduino,
that the Shield was shorting pins 0 or 1 or both thus preventing a good
data transfer. Thanks for everyone’s help… :smiley:

Are you sure you have the correct Arduino board selected, as well as the proper USB port in the Arduino software? I usually see that error when I switch between my Mega and Uno boards and forget to change the board selection to the proper board, or when I have it trying to upload on the wrong USB port.