Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Zumo: Motor just beeps when connected


#1

I’m using a air of mini gearmotors HP 50:1 with the Zumo shield.
I feed it with 6.8V from a bench power supply.
I use a 1 uF ceramic de-coupling capacitor across the terminals.

When I set the shield to go, without motors connected, I can measure appropriate voltage on the output.
When setting PWM to 192 out of 255, I get about 5.1V.
When setting pins 9/10 to high (no PWM) I get the 6.8V.
When I hook up a gear motor directly to power supply, it runs very well.
However, when I hook up the same gear motor to the motor output on the shield, it just beeps vaguely, as if it’s being fed a too-weak PWM signal.
Curiously, this happens even if I just set the “PWM” pins high with no PWM.

What is going wrong here?

Secondly, it seems like one of the two gear motors doesn’t run. It measures infinite resistance, and doesn’t run even when power is applied. The other motor measures about 4 Ohms of resistance.

Other weird thing: The blue and red LEDs are indicated as “direction LEDs” in the documentation, but they are just all on all the time.


#2

OK, so two problems solved, but one still remains.

  1. I removed the 1 uF bypass capacitor, and the motor runs from the controller. Conclusion: 1 uF draws too much start-up load, and the controller current-limits, and the motor never starts. Hence, the “beeping.”

  2. The schematic shows one blue LED powered from Vbat, and one blue and two red LEDs powered from Vin (generated by the boost controller.) presumably, the load of the blue + 2 red is enough to avoid “float-up” of the output voltage of the boost controller. I had thought that red + blue “power” indicators meant power to the motors, but that was just me assuming too much. This means that the shield will draw down any battery that’s connected, even if the power switch is “off.”

  3. The second gear motor still doesn’t work – and now they are on back order :frowning:


#3

Hello, jwatte.

  1. You are right about the bypass capacitor causing the driver to current-limit. The shield has a 3.3 nF bypass capacitor on each motor; in our tests, we found it would not work reliably above 6 V with much more than about 10 nF.

  2. The LEDs are there mainly just to give a visual indication that the shield is switched on and the regulator is working properly. All of the current going from the batteries to the shield, Arduino, and motors passes through the switch, so turning the switch off should prevent any current from being drawn from the batteries. (If you have the Arduino plugged in to USB, though, it can still provide 5V and 3.3V to the shield.)

  3. I’m sorry you got a motor that isn’t working. Just to be sure, it still doesn’t turn even when you connect it directly to a power source, right? Please email us with your salesorder information and we can discuss getting you a replacement as soon as we have the motors back in stock.

- Kevin


#4

[quote] it still doesn’t turn even when you connect it directly to a power source, right?
[/quote]

Correct.

I’ll send that email!


#5

The conclusion to the dead-motor problem was that, when de-soldering, I used too much heat (for too long) to get the wire dis-lodged, which melted the plastic back piece of the motor around the connector. That connector is also the physical mount for the brush on the inside, and the brush had thus moved and didn’t contact the rotor.
Thus: User error!

Re-bending the contact back into place made the motor run again, although not as smoothly as the “real” motor. And the 50:1 is now out of stock (but coming in again soon, I hope!)
Meanwhile, I used the Black Friday sale to pick up a pair of 75:1 motors, and I’m now up and running (using a 2S LiPo, even – see other thread.) The 75:1 gives just fine speed to this device – perhaps the 7.4V of the 2S LiPo helps with that :slight_smile:

Fun little guy!


#6

I was wondering if this thread was relevant to the problem I’m having…

Can you confirm that if the LEDs on the Zumo Shield do not light up, there is a problem with the power regulator? Just one of the blue LEDs light up, not the other three.

Also, the motors only work at higher speeds. They do not move at low speeds at all. Maybe a faulty regulator was causing this too? Are there any voltage measurements I could make to confirm?

I am using a standard Zumo chassis and robot kit.


#7

Hi.

That might indicate an issue with the regulator, but it is hard to say without more information. Did the other LEDs ever light up for you? Are you powering the Zumo shield with the standard 4 AA batteries in the battery compartment? If so, are you using NiMH or Alkaline batteries? What voltage do you measure on VIN? Could you post pictures of your robot?

-Claire


#8

Thanks Claire.

I believe there might be an issue with the regulator. Where is the regulator located on the board, so I can conduct some tests?

I can confirm that there is no 5V or 3.3V outputs either. There is 1.3V on the 5V rail and 0V on the 3.3V rail. The VIN 7.4V output is present however.

Further testing has also shown that one of the LEDs (D3) on the 7.4V line has blown. Shorting that LED causes the other 2 (D6 and D7) to light up. I am powering the Shield using the standard 4AA Alkaline batteries in the battery compartment.

I don’t believe the faulty LED is causing the loss of 5V and 3.3V, but it would be handy if you could provide some ideas on testing the regulator.


#9

The only regulator on the Zumo shield is the 7.4V regulator. The 5V and 3.3V rails are supplied from the Arduino. You could try testing the regulators on the Arduino by supplying power to it directly. You could probably also test the 3.3V regulator by powering the Arduino through USB. If you let me know what kind of Arduino you have and post pictures of it and the Zumo shield I might be able to help you troubleshoot more.

-Claire


#10

Thanks Claire.

I wasn’t aware that the 5 and 3.3V came from the Arduino. I incorrectly assumed that the Zumo provided those voltages too. I had diverted power to a Bluetooth Shield but have now used a bread board to provide 5V to the Zumo Shield as well. And that seemed to have fixed the issue.

I can live with a blown LED as I don’t want to risk any damage to the board.

Again, thanks very much for your assistance. I’m so glad it was a simple fix.