Zumo 32U4: one of the wheels does not rotate smoothly

It worked very well till yesterday, and I don’t know what’s happened (no shocks, I think, but of course I cannot swear).
The right wheel is not rotating freely and smoothly, above all in CCW direction.
I don’t think the wheel was forcedly pushed towards the robot: it does not look jammed though it is. Perhaps some small debris somewhere?
Should I try and unmount the wheel?
It happened just during a class… one robot out of six is now out of order…


There are two sprockets attached to the right tread on the Zumo; is it the Zumo’s drive sprocket that you are having issues with? (This is the sprocket attached to the gearmotor). What is the gear ratio of the gearmotors you are using? You mentioned the sprocket is not rotating freely and smoothly in the counterclockwise direction, but is it working normally in the clockwise direction? Is the behavior the same if you remove the tread? What about if you prop up your zumo on a box or otherwise suspend the treads in the air? Does that sprocket still have issues rotating?

If you are not already using new or fully-charged batteries, can you try replacing them? If that doesn’t fix the issue, can you post a link to a video showing the behavior you are seeing?


Dear Tony,
thank you very much for your kind reply!
I had to leave for a congress so I could neither reply nor try your suggestions (some of them I had tried myself so I can already give an answer). I’ll soon do some tests and come back to the forum.
Thanks again!


I am having the same exact issue, the right wheel being stuck specifically going backwards. It happened suddenly today. Please could you let me know if you ever found a solution? I am afraid the robot is permanently ruined. Thank you


Just to confirm, are you also using the Zumo 32U4? Also, what gear-ratio motors do you have?

If you have not already, can you try testing your Zumo using the MotorTest example program from our library? Can your motor rotate in both directions if you remove the track and sprocket?

- Patrick

I am using the ZumoShield version 1.2 with 75:1 HP Motors
I have done this test only the left set of wheels work, not the right. Removing the track it is the same, the left front wheel works and the right doesn’t. The right feels stiff too, particularly in CCW, when moving it with hand even when the robot is off.

I don’t know how to remove the sprocket, after reading Tony’s advice I looked online but I couldn’t find the instructions anywhere. Sorry I am not very familiar, I am a uni student and so the robot came already assembled.

With the help of my supervisor I managed to remove the sprocket and gear box, it seems the gear box when removed from the motor rotates perfectly smoothly but the motor itself seems to be restricted in CCW movement. Any suggestions? Thanks

Unfortunately, it is appearing more certain that your motor is now damaged. I am not exactly sure what might be causing that type of sort of asymmetric behavior, but there is not going to be a way to fix it. Could you send an email with your order information and a reference to this thread to support@pololu.com? In your email, could you also include a description of how you were using your Zumo when it failed? If there is any visible damage to the motor or any other parts, could you also include pictures of those?

- Patrick