Zumo 32u4 not recognized as USB device


I am currently having a problem with one of my Zumo 32u4 robots. I am unable to upload a new Arduino sketch to it through the Arduino IDE. It appears that the robot is stuck resetting itself over and over, because it keeps repeatedly playing the first tone of the buzzer melody it was previously programmed to play on startup. The device will not show up in a the list of ports in the arduino IDE. I have tried doing the uploading-before-bootloader method but it has failed every time. The device does show up in my device manager while in the bootloader mode, but it shows as an unknown USB device under the USB controller tab, rather than the COM and LPT ports tab. Another things that is worth noting is that for some reason it will go into bootloader mode after having pressed the reset button only once. I have tried reinstalling all the drivers (with the robot unplugged) but it didn’t help.

What could the cause of the problem be, and how would I go about fixing it?
Thank you in advance!


I am sorry to hear you are having trouble with your Zumo. Can you let me know if you have made any modifications to your Zumo and explain how it is behaving in more detail? Does it seem like it is reseting continuously, and is it happening at a constant interval? Please check if the behavior is the same if you power the Zumo via USB with the batteries removed versus if you power it from fresh batteries with no USB connection. Posting some pictures of your Zumo along with the last program you uploaded to it might also be helpful.

- Patrick

We have not made any modification directly to the Zumo, but we have mounted our own shield onto the Zumo which utilizes the 5V, GND, TXD1 and RXD1 pins. The reset seems to be happening at a constant interval. The same behavior is produced both without batteries and with fresh batteries, also with or without our shield.

I believe this is the last program that was uploaded to the Zumo:
zumoCode.ino (2.3 KB)

I am not sure if you wanted a picture of something specific, but I took one of the main PCB. As far as I can tell it is not damaged in any way.

It is hard to tell from the angle of your photo, but it appears that the solder joints connecting the battery terminals to the board might not be fully wetted to the pads, so please try to correct that. Also, I recommend leaving your shield disconnected for now while we try to resolve the resetting issue.

I want to see how your robot appears in the Device Manager when we are sure it is in bootloader mode. Can you remove the batteries and the front sensor array from your Zumo, connect it to your computer via USB, then press the Reset button twice within 0.75 seconds? Immediately after that, please take a screen shot of the Windows Device Manager with the “Ports (COM & LPT)” and “Universal Serial Bus controllers” sections expanded. Can you also tell me what the LED behavior is on your Zumo when you do that?

- Patrick

As I mentioned earlier the Zumo will seemingly go into bootloader mode after only pressing the Reset button once, and pressing it twice only seems to make it exit bootloader mode. When it is not in bootloader mode it doesn’t show up in the Device Manager at all, while if i put it in bootloader mode it will show up under the USB controllers tab but not the Ports(COM & LPT) like shown:

I apologize for the Norwegian language setting. It translates to “unknown usb device (device descriptor request failed)”

As for the battery terminals, I tested the connections and they seemed fine. The Zumo has never had any problems with the battery power either.

Just to confirm, can you tell me what the LEDs on your Zumo are doing when you think it is bootloader mode?

- Patrick

The yellow user LED on pin 13 is flashing on and off. The green VBUS LED is on. All other LEDS are off.

Earlier you mentioned that this is one of your Zumo 32U4 robots; if you have access to another Zumo can you confirm that uploading to it works as expected using the same USB port and cable?

What is the approximate interval between when your Zumo resets itself? From the program you posted it looks like your buzzer should be playing two notes when your program starts; does it always finish both notes?

- Patrick

Uploading works as normal with other Zumos while using the same USB port and cable. The interval is approximately 0.75s measured roughly. Only the first buzzer tone is playing.

Unfortunately, it seems like the USB interface on this Zumo is damaged and will be impractical to repair. It also seems like the motors discussed in your other thread might be damaged. Please email us with your order information, a reference to your threads, and a count of the parts you need to get all your Zumos working again.

- Patrick