Zumo 32U4 Examples Boot but Do Nothing

Hello! I am attempting to use the LineFollower.ino sketch on the Zumo 32u4. However, after the Arduino IDE indicates the sketch upload is complete, the Zumo “beeps” and does nothing. The display remains blank with the top character row all blocks. The standard arduino “blink” example does boot to the Zumo and does blink the yellow LED, indicating that my USB cable is transmitting data. I successfully uploaded several other Zumo examples sketches with the same lackluster results. Before I attempted to upload the line follower program, the factory demo program was working fine. I imagine there is a configuration issue somewhere…what could I have wrong? Thank you!


  • Arduino IDE v1.8.13
  • MacOS Catalina 10.15.5


At the beginning of the LineFollower program, it should display a message on the LCD and wait for a button press. It sounds like your LCD might not be working. With the line following example or another program that uses the LCD loaded, can you confirm that your LCD is connected correctly and try adjusting the contrast potentiometer? If you cannot get anything to show up on the LCD, can you post some pictures of your Zumo that show your LCD’s soldered connections?

- Patrick

I adjusted the potentiometer to no effect. I tried the PushButtonExample, ZumoMotorExample, and Compass sketches in addition to the LineFollower sketch. The PushButtonExample did not produce the expected LED behavior.

What bootloader am I supposed to use?

Since you are able to upload programs, I do not think this has anything to do with the bootloader.

The example programs you mentioned are for our Zumo shield, not the Zumo 32U4, so I think you might be using the wrong library. Can you try installing the Zumo32U4 library by following the instructions in the “Zumo 32U4 Arduino library” section of the Zumo 32U4 user’s guide and try out the examples from there instead?

- Patrick

Oh! I didn’t notice the difference in libraries. Thank you very much! Problem solved.

1 Like