Wixels and Arduino IDE

ok I got two wixels
downloaded “wireless-serial-v1.3-shield”

installed it on two wixels
they are now sitting there flashing their yellow LEDs briefly once a second

connected one of them to a wixel shield sitting atop a seeeduino
t’other is still connected via USB (COM7)

picked a working sketch and attempted to download it using COM7
board type is set to Arduino Duemilanove or Nano w/ ATmega 328
(which is what I normally use when the board is connected via USB)

it compiles ok (sorry verifies!)
both wixels have a brief red wink at one another
LED 13 gets in on that act by winking briefly as well!
followed by:
avrdude: stk500_getsync(): not in sync: resp=0x00
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51

PROB90 I did something wrong

the question is what?!?


Have you configured the Wixels to use the correct baud rate? Check out the Configuring the Wixels section of the Wixel User’s Guide for more details.

- Ryan

I used the default 115200 baud for each
should I try something else?

more information
the wixel that is plugged into the wixel shield now shows a steady red light
when unplugged (and powered via its own USB connector) - no red LED

is that odd or just unusual?

looks like that was it
dropped it to (only) 57600 baud
red light goes out and IDE now uploads correctly

award yourself a <>

thanks for listening!


Different Arduinos/Arduino-clones use bootloaders with different baud rates. The Arduino IDE makes this difference transparent to someone using the traditional USB connection, but when you have Wixels as intermediate devices, things won’t work unless you explicitly configure them to run at the appropriate baud rate.

- Ben

Thanks Ben
I thought they all booted at the same baud rate

got it all working now

even runs perfectly at 3volts

just feed 3 volts (2AA) into the 3.3 volt pin on the 'duino
my sketch works fine with the board in the next room chatting away over the wixels!

Having looked into it a bit more I wonder if I can do the whole job just using wixels - and not use the 'duino at all!

I’m glad to hear that things are working so well for you. Please let us know how your project goes!

- Ben

looking increasingly like it’s becoming a wixel only project!

I do have a further query though
havn’t started looking at the SDK
but I am running the i/o repeater app
very nice wil do 90% of what I want, surprisingly!

I have it configured on the “master” with pins 1-2 to 1-7 as inputs (-2 to -7)
the “slave” has pins 1-2 to 1-7 as outputs (2 to 7)

1-2 to 1-6 work fine
1-7 stays on
I tried 2 wixels as master and two as slave - same result
did I miss something?

curioser and curioser
after downloading the sdk
I recompiled i/o repeater
and now P1_7 is behaving !?!

further update:
tried reloading the original
"transmiiter" end still works
"receiver" end doesn’t set pin P1_7

maybe the source has changed since the original app was built??

Hello, mmcp42.

Two numbers separated by a dash usually denote a range, so it took me a while to figure out what you meant when you wrote “pins 1-2 to 1-7”. It would help if you would use the actual names, like this: “pins P1_2 to P1_7”.

You have discovered a bug in I/O Repeater App v1.0 we didn’t know about that prevents P1_6 and P1_7 from being used as outputs! The source code of that app has changed a lot since we released it, because we changed it to use the new gpio library. When we made those changes, the bug went away. We will release a new version of the I/O Repeater app soon, but for now you should use the version you compiled yourself. Thank you for reporting this.


We have released the new, fixed version of the I/O repeater app (v1.1): pololu.com/docs/0J46/9.d