Wixel windows XP install missing dll SOLVED

I’ve been using wixel on windows 7 - works fine
tried to install it on an XP machine
all installed ok
tried to run the wixel configuration utility
got the error

WixelConfig.exe - Unable To Locate Component
This application has failed to start because WINUSB.DLL was not found. Re-installing the application may fix this problem.

re-installed and got the same message
checked the zip file - no evidence of WINUSB.DLL there either
is it supposed to be part of windows?!?

I am having this exact problem as well.

Works great on windows 7 but not on XP.

What needs to be done to fix this ?


I tried to download the dll
but it keeps arriving with zero size!?!

and, big surprise, that doesn’t work!


I am sorry you having trouble with the Wixel software. It seems that WinUSB might not be installed by default on Windows XP (unlike Vista and 7), so this is something we will have to look into. Could both of you let us know what Service Pack of Windows XP you are running, and whether it is the 32-bit or 64-bit version?

- Kevin

hello Kevin
Windows XP Professional
Version 5.2 (Build 2600.xpsp.080413-2111:Servide Pack 3)
32 bit as far as I recall

I tried downloading the dll from an alleged microsoft site, although the link was odd
it kept arriving with 0 size, so I binned it!


Hello, mmcp42 and JT.

Unfortunately, for Windows XP computers, winusb.dll only gets installed after you complete the Found New Hardware Wizard for a Wixel that is in bootloader mode. Thank you for alerting us to this. We might have better workarounds in the future, but for now, please:

  1. Get the Wixel in to bootloader mode and plug it in to the Windows XP computer. There are three different ways you could do this: you can erase the Wixel using the Wixel Configuration Utility on another computer so it has no app on it, you can use a wire as described in the “Connecting Buttons and Starting the Bootloader” section of the Wixel User’s Guide, or you can open a terminal program to the Wixel and set the baud rate to 333 (assuming it is running an app that has a virtual COM port).
  2. Complete the Found New Hardware Wizard to install the drivers for that Wixel’s bootloader. This is when winusb.dll gets installed. When this is complete, you should see an entry for “Pololu Wixel USB Bootloader” in the “Pololu USB Devices” category of the Device Manager.
  3. Run the Wixel Configuration Utility. It should work now.

Let me know how this works for you.


put Wixel into boot mode (just stopped the app)
connected it to XP running in a virtual machine so didn’t have to power it down or move anything, just connect it to the VM
up pops (well eventually!) the install wizard
does its thing
Wixel config utility works!
start the app
install wizard pops up again
does whatever it does

all seems hunky and dory now!

(means I can finally debug my terminal monitor properly no- no excuses!)