Wixel Shield + Arduino Nano RP 2040 Connect

I have a wixel shield that I used with my Uno for a previous project. It was extremely useful because I was able to seamlessly upload sketches and debug wirelessly. Going through the manual for the shield I understood that it only needs to connect to 5 pins of the arduino (5V, GND, RESET,TX & RX). I first attempted connected these 5 pins alone (instead of plugging the entire shield) with my Uno and the wireless functionalities worked perfectly. However, when I try to do the same with the Arduino Nano rp2040 connect, I get the “Error while uploading the sketch” message in the IDE. Can someone help me understand if there a simple solution I am missing or are the two (rp2040 and shield) just not compatible?
The things I have tried till now are:

  1. switching from one of the reset pins to the other.
  2. Double clicking the reset button on the Nano to enter bootlander mode before uploading the sketch.
  3. Made sure I selected the correct board and COM port on the arduino IDE


We are not very familiar with that board and have not tested it specifically. However, it looks like it might not be designed to be programmed via TTL serial. If that is the case, you would not be able to use the Wixel shield to program it. You might try posting on the Arduino support forum to see if they can give you any advice about programming it serially.


Thanks for the response. I did manage to upload a program through the wixel’s COM port using the arduino IDE and I would like your help understanding how it worked because I don’t fully understand it.
So, the wireless upload was successful under two conditions,

  1. while uploading, I had to press the reset button (either on the arduino or shield) 10 times in order to upload successfully.
  2. The arduino had to be plugged into the computer(I know that beats the purpose of the shield, but the fact that it worked means the nano CAN be programmed using UART, right?).

Note: When I upload through the arduino’s COM port none of the above is required.

Correct me if I’m wrong, but from my understanding, it seems like it is possible to upload sketches via UART its just that the nano should be in a certain mode, which only happens when the reset button is pressed while it is plugged into the laptop. Does this make sense? Shouldn’t nano respond to the reset button the same way even if it isn’t powered through a computer?

As a simple test, could you try using that same setup that worked and try doing it again, but with the connections from the Wixel’s TX and RX pins removed this time, and see if it still works?

As I mentioned before, we are not very familiar with that Arduino Nano 4020 board, so I cannot offer any specific suggestions for that. However, you could double check that your Wixels are functioning properly by testing them with a known compatible board, like the Arduino Uno setup you mentioned having used successfully before.