Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Wixel SDCC

I just downloaded the Wixel SDK from github and SDCC from souceforge. I tried make and got the following error:
Creating libraries/lib/radio_com.lib
/bin/sh: sdcclib: command not found
make: *** [libraries/lib/radio_com.lib] Error 127
From the SDCC documentation sdcclib was removed from the package in 3.8 and sdar replaced sdcclib.
I edited the makefile, and set AR := sdar#, this gave me the following error:
Creating libraries/lib/radio_com.lib
sdar: two different operation options specified
make: *** [libraries/lib/radio_com.lib] Error 1

I edited the make file again with the following changes:

AR_FLAGS = -rc
ARCHIVE_COMMAND  = $(AR) $(AR_FLAGS) $@ $^

This solved the issue, hopefully it was the correct way to fix the issue

Hello.

Thank you for reporting the problem to us and for sharing your solution. That seems like a fine way to fix the issue.

Did you manage to successfully compile Wixel apps with SDCC 3.9.0 in Windows? Even after using your fix, I encountered multiple other issues which make me think that Windows users should probably keep using SDCC 3.8.0 and sdcclib for now.

–David