Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Wixel doesn't appear on Wixel configuration utility


#1

Hello,

I am a new in using wixel and I have question related to it. I installed the Wixel configuration utility and I connected the wixel to it and it appeared to me in the configuration utility. After I upload my code to the wixel the chip not appeared in the configuration utility. I would like to know if the chip is work or broken so I can find way to fix it.

Regards,


#2

Hello.

It sounds like you might have loaded an app that does not implement a standard USB interface, which the Wixel Configuration Utility will not recognize. For more information about this, you can see the “USB Configurations Recognized by the Wixel Configuration Software” section in the Wixel’s user’s guide Can you try manually putting your Wixel into bootloader mode by following one of the two methods listed under the “Connecting Buttons and Starting the Bootloader” section of the user’s guide and seeing if the Wixel Configuration Utility is able to detect your Wixel in bootloader mode?

- Amanda


#3

Hello, Thank you for your responding…

The wixel works now. I have another question: I tried to compile the wixel-sdk folder and I got the following error:

Compiling libraries/src/usb/usb.rel
libraries/src/usb/usb.c:292: error 146: two or more storage classes in declaration for 'usbStandardDeviceRequestHandler’
make: *** [libraries/src/usb/usb.rel] Error 1

I didn’t change the code so I would like to know is there any problems related to the SDCC or GCC versions!

Regards,


#4

Hello.

I suspect you are using an old version of the Wixel SDK with a new version of SDCC. The error you are getting was fixed in wixel-sdk commit b15bfa6 in July 2015. I recommend downloading the latest version of the Wixel SDK from https://github.com/pololu/wixel-sdk and trying again.

–David