Wixel Configuration Utility will not launch in Windows XP

I am interested in getting started with the Pololu Wixel. I downloaded and installed the Wixel Configuration Utility to make sure it works with my computer and to make sure I can use the wixel before I buy it. I was running Windows XP Service Pack 2. When I tried to launch the utility I got an error message saying “This application has failed to start because WINUSB.DLL was not found. Re-installing the application may fix this problem.” I have tried re-installing and re-downloading. I also updated my computer to Windows XP Service Pack 3, which Pololu says is supported for the utility, and re-downloaded and installed again with no change. Can anyone offer any suggestions?

Hello, AIProgrammer.

We have encountered this problem before. The first time you plug in a new device that uses WinUSB and go through the Found New Hardware Wizard, Windows XP will copy winusb.dll into the right place. Before you do that, winusb.dll can not be used by programs that require it, like the Wixel Configuration Utility. For Windows XP users, it is important follow all the steps in our driver installation instructions before running the Wixel Configuration Utility; otherwise you will get that error message.

This problem only applies to Windows XP.

There should be a copy of winusb.dll somewhere on your computer. If you can find it, you can try copying it into the same directory as wixelconfig.exe (C:\Program Files\Pololu\Wixel\bin). This should allow our program to find the DLL, but this non-standard installation of winusb.dll could cause other problems. Even if it works, I would delete the extra copy of the DLL later, when you get the Wixel.


Thanks, that’s exactly what I needed to know. I’ll probably just go ahead and get a wixel and not mess with moving the DLL.