Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Wixel can't run bootloader


Hello Guys,

I need help for my wixel module - the app I had written on it has suddenly stopped working. It had the yellow and the red led lights on. Tried to connect it to my laptop but it would not show up in the Wixel Configuration Utility. Then I opted for the manual bootloader mode - 3.3 to 2_2 pins connected. Unfortunately now only the yellow LED light is on and it still doesn’t show up in the Configuration Utility. The dmesg -wH command does not show any attempt for USB connection. As far as I am aware, if in bootloader mode, the green light should blink, but I only have the yellow light turned on (no battery or external power source is connected to it except the USB cable to the laptop). I am following the correct steps and tried many times to ni avail. Please share your advices on the case:



I am sorry your Wixel stopped working. Can you tell me more about your system? What App were you running when the board was working? Did anything in your system change in between when the Wixel was working and when it stopped? When the Wixel is not in bootloader mode, does the green LED light up when the Wixel is connected via USB? Also, can you verify that the USB cable you are using works with other USB devices?



Thank you for your reply. I was running xDrip app and it suddenly stopped transmitting data. Right now, if I connect the P2_2 and the 3v3 pins and then plug in the USB I get a constant yellow light. If I connect just the USB cable, there is no led light working. The cable I use is brand new and definitely works. Tried with another cable and the result was the same.


It is sounding like your Wixel might be broken. Just to check: can you specifically describe how you are connecting 3V3 to P2_2? It looks like that would be hard to do with the pictures you have shown because the 3V3 pin is soldered to a wire that goes to something else. If you can send pictures of the connection, that would help me look for anything obviously amiss.