Wixel and CHR-6d


for my project I am using two Wixels and sensor CHR-6d:
Links :

I also used when everything was fine Pololu USBtoUART module :

When I connected sensor through USBtoUART module and took measurements from my PC everything worked fine(when I logged data from sensor I got constant timestep)

Now when I am using Wixels(which will be used for wireless communication) I got messy timesteps. They are smaller as set on application on PC. This probably means I receive data faster than required.

When I saw things doesn’t work I tried with Wixel USB-UART communication but the problem remains the same. Timestep is not constant.

Best regards,


I am sorry you are having problems with your Wixels. I am not sure what you mean by:

Also, can you clarify this as well:

If you provide more details about your system and what you are experiencing, it might help us solve the problem. For an idea about what to write, see our support page.



thanks for fast response. :slight_smile: I will describe my problem more clearly.

  1. Using connection PC-USBtoUART Pololu-CHR 6-d with PC application(IMUKit)

Results obtained from sensor are attached in picture constant.png

PC application worked just fine.

  1. Using connection PC-Wixel(OSB-Serial app)-CHR 6-d with PC application(IMUKit)

Results obtained are in picture messy.png. Programme was set to Broadcast mode with 100Hz, but results show that we have less than 10ms timestep.

You can see that timestep is not constant anymore, there is more than 1ms error

One problem is that i don’t have USBtoUART here anymore so I can’t test it again.

Any suggestions would be very appreciated.

Best regards,


for my application I am using CHR 6d and Pololu USBtoUART converter and IMUKit application for monitoring sensor data.

Links :

Some problems occured now, please see picures in appendix(constant and messy)

Constant picture shows data where timestep was constant, messy picure describe problems I have now.

I don’t remember what was different when I got constant time step, but now I tried everything to get it but with no succes.

I would very appreciate any help.

Best regards

Hi, nejcmedv.

Earlier you mentioned our #1308 serial adapter, but just now you linked to the #391. Which one do you have, or have you tried both? Was it previously working with one of them, but not any more? Are you currently getting the results you expect with any of the adapters?

It doesn’t seem like the choice of serial adapter could account for the differences in the timesteps you saw (~8 ms vs. ~62 ms). Did anything else change over the course of your tests? Did you change the baud rate or any of the IMU settings?

Other than that, all of your results seem fairly reasonable to me. In general, you shouldn’t really expect any more accurate timing than on the order of a few milliseconds, especially when USB and a desktop or laptop PC are involved. If you need more accurate timing, instead of interfacing the IMU with your PC directly, I would suggest connecting it to a microcontroller that performs the timing-sensitive task of reading the IMU regularly, then passes the data (with or without further processing) on to your PC. I remember trying to help you use the IMU with an Arduino in your earlier thread; did you ever get that working?

We aren’t really familiar with IMUkit or the details of the CHR-6d, so if you think the problem has more to do with those, you might consider contacting CH Robotics directly.

- Kevin