Windows 7 64-bit can't install the USB programmer drivers

I’ve installed the Polulu AVR programmer bundle 120913 on my Windows 7 x64 computer but when I try to connect the programmer I get an error about the driver:

Windows encountered a problem installing the driver software for your device

"Windows found driver software for your device but encountered an error while attempting to install it.

Pololu USB AVR Programmer

There is no driver selected for the device information set or element."

I tried to manually install the 3 inf files under c:\program files (x86)\pololu with right click and also install the driver manually from Device Manager to no avail. Any advice?



I am sorry you are having trouble with your Pololu USB AVR Programmer. Could you please tell me the exact names of all the entries you see for the programmer in the Device Manager? Be sure to look under “Pololu USB Devices”, “Ports (COM & LPT)”, and “Other devices”. Also, could you double click on each one and go to the Details tab and tell me what its Hardware Ids are?


Hi David,

thanks for your support. I can find 3 devices listed under Other devices, and they have the yellow icon with an exclamation mark: Pololu USB AVR Programmer, Pololu USB AVR Programmer Programming Port and Pololu USB AVR Programmer TTL Serial Port.

I’ve attached 3 screenshots from Device Manager with the hardware IDs.

For your information, these computers are in a computer lab in our college since we plan to use 3pi robots for a class and they have Windows 7 64-bit.

Please let me know if you need more information to troubleshoot the problem.


Thank you for the screenshots. The yellow icon with the exclamation point means there is some error and you should be able to see the error in the General tab. To get a better idea of what is going on, could you tell me what it says in the General tab for each of those devices?

Some basic suggestions for troubleshooting: Have you tried unplugging the programmer and plugging it back in? Have you tried it on other computers on the lab, and do they all behave this way? Have you tried other USB cables and other ports?


David, sorry for late reply. After some troubleshooting from our IT department, it turned out to be a problem with Faronics Deep Freeze: they had to redo the installation a few times before finding the right way to capture it properly. Now everything is working.

Thanks again for your support!