Windows 10 does not recognize my A-Star 32U4

Have a “new-ish” (9 months old) Windows 10 laptop that I’ve installed the latest drivers on, but when I plug my A-Star into it, nothing happens except for the board powers up. Nothing is shown in the Device Manager and there was no activity from Windows trying to recognize that I plugged something into my USB.
I’ve tried a couple of different USB cables and also another A-Star that I know is operational (last worked several months ago when programming from my Mac).

What other things can I try?


Did your Windows laptop recognize your second A-Star? When was the last time the problematic A-Star worked for you? Which version of the A-Star programmable controllers do you have? Can you try loading the BlinkLEDs sketch again onto the A-Star using the reset button revival method described in the “Reviving using the Arduino IDE” section of the A-Star 32U4 User’s Guide?

Also, if you are using a USB hub, can you try connecting it directly to one of the USB ports on your computer (one that you know is working)? If the A-Star is still not recognized, can you select the “Devices by connection” option under the “View” menu in the Device Manager, expand all of the “USB host controller” entries, and post a screenshot of that window here?

- Amanda

I have the 32U4 (ac01a) controller. Attached is a shot of what is listed in Device Manager with the controller connected via USB.

Please answer all of the questions in my previous post. That screenshot of your Device Manager is still viewing “Devices by type”, not “Devices by connection”. You can select the “Devices by connection” option under the “View” menu in the Device Manager.

- Amanda