Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

When plugged in, Wixel leds dark, Wixel not present in lsusb


#1

Hi,

I was working with my Wixel pair this morning and performed a “write to wixel” using wixelconfig. A permission denied error was issued in the console and that particular device no longer illuminates any leds nor shows up in lsusb when plugged in. The other wixel seems to work fine as normal when plugged in to the same port, cable, etc… That is, it shows up in lsusb and the leds illuminate. When I plug the “dead” wixel into my antique Windows XP computer, I see the same behavior. It remains dark and doesn’t show up in the device manager, the good wixel does show up and illuminates its leds.

In my limited experience with these devices, I’d guess that I killed it somehow. Do you think that’s true? If so, do you know any technique I might use to restore the device to an operating state?

Thanks,
Rich.


#2

Hello, Rich.

I am sorry you are having trouble getting one of your Wixels to work. Can you try manually getting that Wixel into bootloader mode? If it does, you should see that the green LED blinks and the USB connection should work. If you are not sure how to do this, you can refer to the “Connecting Buttons and Starting the Bootloader” section of the Wixel’s user’s guide, which you can find under the Resources tab of the Wixel’s product page.

Also, what operating system are you using? If you get the same error to happen again, can you post a screenshot that shows the exact error message you are getting?

-Jon


#3

Hi,

Thanks for the response. Your advice was spot-on, I was able to get it back using the technique in the guide. I have a vague feeling I’ve done this before which makes me feel even sillier.

I’m using CentOS 7.1.1503 It’s not clear to me where the permission denied errors were coming from. The /dev/ttyACM* files are all fine, I’ve checked and double-checked the permissions and udev rules. I think it must be in /run/lock but I couldn’t find what was causing it. I am running selinux but I didn’t see a conclusive record in the audit log. I had repeatedly dumped strace and didn’t see what’s causing it. Oh, wait, I must have fixed it before I sent my original post and got confused when the wixel became unresponsive. After recovering, I just ran wixelconfig again, writing the program to the wixel, and this time it worked without any issues. The program I loaded seems to have sent it off to it’s quiet place but I didn’t get a permission denied error. The manual reset recovers it so I’m back to work.

Thanks for your help!

Rich.