Voltage Regulator Shutoff (D15V35F5S3)

I am trying to use my Pololu D15V35F5S3 regulator as a portable power supply for a board that operates normally from a switching wall-wart power supply (5V, 2A). The board operates fine from the wall supply.

The input to the regulator is a 7-cell NiMH battery (8.4V). The regulator puts out 5.0V under no load, as measured with a voltmeter.

However, when I hook it up to the load, the regulator seems to shut off. I thought it was toasted because it wouldn’t come back on even after removing the load. After an indeterminate amount of time though, the regulator came back to life. I was dumb enough to do this three times, and each time the regulator is dead for a while before reviving itself.

This made me think it might be something to do with an automatic shutoff on the regulator. Do you guys have any idea what could be going on? I can’t imagine that I’m overloading the regulator – the board I’m connecting nominally draws ~1A.



It sounds like you are either drawing too much current or your battery is not well charged. Can you describe your setup in more detail (maybe include a picture)? Can you measure how much current your board is drawing and your battery voltage to make sure it is charged?

- Ryan

Attached is an MS Painted schematic of my setup.

I suspected that the battery voltage may have been an issue – one of my attempts was after charging it overnight, after which it was well over the nominal 8.4V.

I also tried swapping in a 12V supply for the battery, with the same result.

The board is a Best Buy Infocast, very similar to a Chumby One. Its power requirements are here (ignore the part about a battery charger, the Infocast doesn’t have one). I’ll see if I can measure the current tonight, but I doubt it ever exceeds 2A.

I think I’ve figured out the problem, but not a good solution.

I measured the current drawn by the Infocast, and on my ammeter it never exceeded 250mA from the wall supply in the state I’m using it.
I then tested a 250mA resistive load across the switching regulator, and it did fine, no shutoff.
I then “jump-started” the switching regulator with the wall supply and a diode, and I’m able to run the Infocast board off the battery/regulator.

It looks to me like the regulator can’t handle the momentary startup current without triggering its shutoff. This seems strange to me. I’d like to avoid adding a capacitor and a switch on the 5V side, as this will eventually get buried from easy access. Any ideas? Inductor?


It would be nice to get a better understanding of the problem, but if you really just need 250 mA, you could put a small resistor in line with your load. Something like 1 ohm could be okay, and maybe you’d need to make it a bit smaller if you need the voltage to stay closer to 5V.

Do you have access to an oscilloscope to get a better look at what is happening?

- Jan

Thanks for your reply.

I don’t have access to an oscilloscope, but I do have the SLO-scope on your AVR programmer, which would probably work for this application. I’ll look at that tonight.

250mA is the load when the board is doing nothing, but when it’s thinking and USB peripherals are connected, it probably goes up to 1A. Resistor is probably not an option.

What triggers the shutoff? My understanding of the product page is that there’s two shutoffs, a current-based one at 4.5A, and an over-temperature one. Since it happens so fast I’m guessing it’s the current-based one. Do you know how this is handled on other switching regulators, such as commercial wall-wart ones?

I looked at the regulator output with the SLO-scope (Channel A) while connecting the battery to its input, and lo and behold it worked ~90% of the time now, for some reason. There were still some instances that the shutoff kicked in, and I’ve attached the three captures I got. Sorry that none of the events are captured in the lower display, this was my first time using the SLO-scope and I only have two hands.

Can’t think of anything I did differently today.

There isn’t some global way overcurrent protection is implemented, and something like this regulator is fundamentally different from a wall-wart.

If you’re getting inconsistent results, the cause might be difficult to track down without better tools. By the way, did you put in the voltage dividers to protect the SLO-scope inputs? You can also just drag the window you’re looking at in the top pane so that we can actually see something in the main view.

Also, can you post some pictures of your setup?

- Jan

Sorry, my question wasn’t too clear. I was referring to how switching power supplies handle momentary high currents.

Thanks for the tip on the SLO-scope, in retrospect I feel a little dumb for not figuring that out. I did not put in voltage dividers, since I wasn’t expecting voltages substantially higher than the USB’s +5V.

Here is a picture of my setup. The big green board is the Infocast that I’m powering. The regulator is tied to the bottom of the clear acrylic piece, and the battery is below everything with the connector sticking up on the left.

No new scope images … I didn’t encounter the problem tonight in ~50 off/on cycles.

So, after working most of the time for the last three weeks, my regulator kicked the bucket tonight. There was a squealing sound when connected to the battery input (with nothing attached the output, this has been my procedure). I disconnected the battery pretty quickly, and reconnected it after a few minutes. No squealing, but the output reads a measly 2.4V with no external load.

I don’t think that I’ve been using it wrong. Any ideas on what has happened? Have you seen any similar cases of failure?

I am sorry to hear that. I can’t really tell much from the discussion so far, and I don’t recall any other failures like this. Is there anything you know you did to get it at least mostly working? Do you have anything you can report that happened right before the squealing (e.g. change in load, something got jostled, etc.)?

If you want to give another one a try, you can contact us directly and we can send you a coupon for a free one.

- Jan

I would typically power up the regulator on the battery with no load (this always worked, and I could measure ~5V on the output). I would then attach my devices, and if things worked, I’d let it be – if not, I’d disconnect everything and try again.

The time it squealed and died, I hadn’t powered it up for a couple days, but I can’t think of anything that was different.

I ended up using a trusty old linear regulator with a big heat sink, but I would like to give another one a try, thank you for the offer. I’ve contacted Pololu directly by email.