Voltage Regular Not Starting Up Raspberry Pi Pico

Using 5V Step-Up Voltage Regulator U3V40F5 with vin from supercapacitors, the raspberry pi pico never powers up. It will only do so if I detach and reattach vout from the regulator after we get to 5V. Was thinking this may have to do with the voltage soft-start never fully allowing the Raspberry pi to boot.

Any thoughts? Thank you in advance!

You might try monitoring the voltage at the input and output of the regulator with an oscilloscope while you try to boot your system to see what is going on (and preferably post screencaptures here). What super cap are you using, and what voltage is it charged to? Have you tried with any other power sources?


Hey Brandon!

Thank you for your reply!

I’m using 2 2.7V 10F supercaps, with a diode and power resistor beforehand to limit inrush current and backpowering. I also have a charge balancer between the two supercaps. They are charging to about 3.7V pretty quickly between the two, so thats the consistent Vin for the regulator.

I will work on getting that oscilliscope reading and posting screencaps here. Was thinking maybe I could use this voltage detector to power cycle the pi while waiting for the regulator to output 3.3V Reset / Enable Controller - KA75330 3.3V Voltage Detector : ID 3428 : $0.50 : Adafruit Industries, Unique & fun DIY electronics and kits

Thanks for the additional information. Are you really charging 2.7V capacitors to 3.7V (in my experience super capacitors are usually very susceptible to over-voltage)? Could you post some pictures and/or a diagram showing how you have everything connected?

It’s hard to say if some kind of reset/enable controller like that would help without knowing for sure what is causing the problem, so I suggest getting some scope captures before trying something like that.


Hey yes! Let me attach the schematic. In combination, the two are charged to about 3.7V from a 5V power source. They usually hover there and don’t get all the way up to the ~5V, so that’s why I started using the voltage regulator in the first place!

Let me know if this helps. Thank you again for your support! Working on getting those captures, had to order a new oscilloscope.

Power Resistor
Charge Balancer

Hey Brandon! Here is the oscilloscope output for Vin (voltage into the regulator) and Vout (voltage out of the regulator). Looks like once the Vin hits around 1.8V, it takes ~2 seconds for Vout to creep up to about 2V and then it shoots up to 5V

Is that scope capture taken with the Raspberry Pi Pico connected? If not, could you post an updated capture with it connected?

I do not see anything obviously out of the ordinary from that capture; the minimum start-up voltage for the U3V40F5 regulator is 2.7V, and it looks like VOUT jumps to 5V when VIN climbs to 2.7V, so that seems normal. However, it looks like the time scale is set to 1 second, so you might need to zoom in to see if there is any irregularities.


Hey! Yes the Raspberry pi pico was connected in this capture.

I set the time scale lower, and still seeing something very similar, no irregularities! I think what’s happening is somewhere in that 1-2 volt range the pi is turning on, but the power is too low so it never boots up. I tried adding a 3.3V voltage detector on the 3v3_EN pin of the pi and that works just fine. Hardware boot is not enabled until that 5V output begins.

I know that many RP2040 designs don’t really like a slow voltage ramp on its Vcc pin. I don’t know if the regulator on the Pico board itself is as sensitive though.

The RP2040 will start running when its Vcc pin hits 1.8V but most of the FLASH chips used with it won’t run reliably until their Vcc gets closer to 3.3V. When the BootROM can’t read the FLASH it will enter USB bootsel mode. The typical fix is to hold RUN low until Vin stabilizes.

If you scope the regulated 3V3 pin on the Pico do you see it jump to 3.3V or do you see similar ramp ups?

1 Like

Yeah I came to the same conclusion! However when I held the run pin low with this voltage detector (Reset / Enable Controller - KA75330 3.3V Voltage Detector : ID 3428 : $0.50 : Adafruit Industries, Unique & fun DIY electronics and kits) it just kept cycling that way, even when the pin was held high. Not sure why. However, when I hold 3V3_EN low until it reaches 3.3V, the pi boots as normal