VL53L1X suddenly not reading distances


I have been working on implementing two VL53L1X sensors into a design and programming them with in the Arduino IDE. I was seeing if I could power one of the sensors off of a separate battery supply but I started receiving readings from the sensor that all read as 0. I then tried running this sensor off the Arduino board’s power and was still reading distances of 0. Even when I went back to testing a Time-of-Flight sensor I knew gave me correct readings with the same code I still saw it reading distances of 0. I have not made any changes to the code since the last time I ran it but now I’m only receiving distance readings of 0 and I am unsure why.

Some further info is my range status reads as valid and my peak signal and ambient count rate are both 0.00. What can I do to get proper readings again or what could be causing this sudden problem?


If you have not already, can you try testing each of your VL53L1X sensors individually using the unmodified ContinuousWithDetails example program from our VL53L1X Ardunio library? If you are able to confirm that both of your sensors work that way, then you could try the ContinuousMultipleSensors example next.

If the example programs do not work, could you post some pictures of your setup that show the boards and all of your connections?

- Patrick