Verifying Arduino Examples for Zumo (Solved)

I am not feeling very smart right now. I received the Zumo today and I’m just trying to put the simple line follow code in it to get an idea of how the robot behaves and tweaking the code. I downloaded the GitHub files but I can’t verify any of them in Arduino. I’m not good with writing code from scratch, I only have one other Arduino robot and that has a “ReadWriteAnything.h” and “Move_data.h” files added to the sketch. So, I apologize for asking a sophomoric question, but where can I find other files to get the examples to verify in Arduino and load to the Zumo?

Scott Callahan

Hello, Scott.

It sounds like you are having trouble compiling one of the Zumo example sketches using the Arduino IDE. I suspect that the libraries for your Zumo were not properly installed. Please make sure that the Zumo libraries are in the “libraries” folder of your Arduino sketchbook directory, which you can find the location of by selecting File->Preferences in the Arduino IDE.

By the way, if you do not already know, we make two versions of the Zumo: the Zumo 32U4 Robot and the Zumo Robot for Arduino. You should verify that you have downloaded the correct library for your Zumo version.

- Amanda

Thank you. I’ll recheck my work when I get home. I included the .h files, do I need a read write file too?

Ok, I got home and verified that I was using the Zumo for Arduino code and that they were in Library in Arduino. I also tried compiling a sketch both just by it self and including all the .h files for buzzer, motors, array, etc. No matter what I do this is the errors I get. I also tried it both as was downloaded from Github, like you see and I also tried it including #define in front of buzzer, motors etc.

Any help is appreciated.

Thank you for your help Amanda. I tried multiple ways with no success (zip files, updating the Arduino IDE to the current version, manage libraries, etc). Then I took each individual folder out of the Zumo Master library and put each folder into my library folder. Now it works. Oddly my other robot using Arduino does not use libraries like this. Hmm? I wonder if I should try to switch it’s .h files to the library like the Zumo.

I am glad you were able to figure out your issue and fix it; thank you for letting us know.

Since it sounds like you are able to compile and program both of your Zumo for Arduino robots, I recommend that you keep the library files in their current directory and not try to move them (or their header files) to a different directory.

- Amanda

My other robot is a biped that’s uses Arduino. But I agree, I’ll just leave that one as is, with the headers attached to the sketch since that works. Thank you for your help.