Using a Micro Maestro 6 with Servocity SPT200 Pan & Tilt

Hi. I need help with my Servocity SPT200 Pan and Tilt mechanism hooking up to the Micro Maestro. I am using Hitec HS-485HB servos in it. I have the Micro Maestro hooked up to the USB, and only have the one servo hooked up in the Servo 0 spot right now. I have put a Futaba NR-4J 4.8v battery in to power the servo on the pins above the Servo 0 pins. I ran your first “blink the red led” test and everything worked fine. I then ran this program:

# Move servo 0 to five different positions, in a loop. begin 4000 0 servo # set servo 0 to 1.00 ms 500 delay 5000 0 servo # 1.25 ms 500 delay 6000 0 servo # 1.50 ms 500 delay 7000 0 servo # 1.75 ms 500 delay 8000 0 servo # 2.00 ms 500 delay repeat

The servo moved- once. After that I have tried several things ( changed servos, changed baud) but have gotten no more response. My initial guess is that the battery is kind of old and may need charging- but I hope its something in the coding or the way I have hooked it up is wrong. Any thoughts? Thanks for your help in advance.

Hello.

I am sorry you are having trouble controlling your servos. Your code looks fine; the problem could be with the battery. Can you try using another battery or power supply? If that does not solve the issue, can you also post pictures that show all of your connections?

-Jon

Yep, got my 6v power supply today and that was the problem. Thanks!