USB serial adapter no communication

I’m trying to get the Pololu USB-to-Serial Adapter (Product 391) to show any signs of communication. The drivers went on fine, and Windows XP sees it when it’s attached and doesn’t when it’s not, so I don’t think the problem is on that end. But when I try Hyperterminal or Bray’s terminal, there’s no activity whatsoever. Both the driver and terminal are set the same, usually on COM 10 at 9600 baud, 1 stop bit, no parity, and no control flow, but all other combinations I’ve tried fail, too. The red LED remains lit solid the whole time. (I don’t know whether it’s supposed to flash during communication.) RX and GND connected to my oscilloscope show a constant 3.5VDC or so, but no signal activity. Hyperterminal shows no progress when sending a file with any protocol, and it eventually times out.

Except for the scope, I have nothing connected to the serial side of the adapter. My understand is that it should still receive, even if I’m discarding the data. I know I didn’t short it out because I’ve never attached anything else, and I’ve been very careful about ESD. I’m an engineering professor (electrical and computer), so I think I know what I’m doing.

I do have an FTDI USB-serial driver installed for other communications, I don’t see how it could be interfering.

Any ideas? I found nothing remotely relevant on this forum, so I think everyone else gets this to work easily. Mine might be DOA, but I’d like to have a definitive test before getting a replacement.


Hi, Dan.

Thank you for your detailed description. RX is an input, as described on the product page, so you should not expect to see communication on that pin coming from the computer. Have you tried looking at TX?

- Ryan

Thanks for the quick reply. I was actually a little quicker in realizing I had the two swapped. I had it stuck in my mind that the adapter is receiving from the computer, which it is. But the RX/TX pins are on the serial side, so it’s the other way around.