USB programmer not detected by Win7 ? [SOLVED]

I just but the first of a batch of Pololu 3pi robot+programmer bundles for an internal company hacking competition. Frustratingly I can’t even get the USB programmer working.
I would greatly appreciate any help.


  • Windows 7 32 bit
  • USB Second generation programmer (product 1300)


  1. Read the manual by the letter, which describes the Vista/Win7 installation as very straight-forward.

  2. Downloaded and installed the driver: … 110524.exe

  3. Rebooted windows

  4. Plugged in the USB programmer (no target board connected)

Windows 7 detects that something is connected to the USB port but it cannot install it properly. Classic #$"#%" error message like: The device was not properly installed…

Am I doing something wrong? I will try on my linux box tomorrow, but I need to get this working on both linux, mac, and win. (I realize I have to reflash the firmware on the programmer for Mac support)

— erik

Should any of the diodes be on when the programmer is plugged in to the USB port?
The programmer seems completely dead, none of the diodes are lit.

Right after I received the programmer I plugged it into my Mac. That was before I read in the manual that I had to reflash the firmare to use it on a mac. But actually, when I connected it to the mac I remember the diode(s) were flashing for a while.
I think the same happened the first time I plugged it into the Windows computer. But then it just became dead.


  1. Will it harm the programmer to plug it into a Mac before I have reprogrammed the firmware (hardly)

  2. Does anyone know which pins on the IC I can measure to debug if signals are ok. I have a scope etc.

  3. Will it help in any way to manually put it in programming mode as described in the manual, by shorting the two points described?

  4. Can I use any ISCP programmer with the 3pi robot? I have another USB programmer from ERE…

This is really frustrating. I’m thinking about ordering more USB programmers from Pololu as this is most likely broken, but I really don’t know…

Hello, erik.

I’m sorry you are having trouble with the programmer. I believe you emailed us on Sunday, but you might not have gotten the reply I sent yesterday morning. Just now I sent my reply to the email address you registered your forum account with, and I hope it will resolve your problems.

From the description of the four steps you followed, it does not sound like you are doing anything wrong. Rebooting the computer (step 3) was unnecessary but okay.

Yes, you should see LEDs on the programmer light up when you plug the programmer into a USB port, with three exceptions: if the computer is off, or if the computer has chosen to shut off power to the USB port, or if the computer has chosen to put the device into low-power (suspend) mode, then none of the programmer’s LEDs would be on. As long as your computer is on, all of those cases are pretty unlikely.


Thank you for letting me know you have a scope; that might be useful later. If there is hardware damage to the programmer, it is probably in the USB connector itself or the 4 connections from the USB connector to other components on the board. If you could visually inspect that area for damage and check for electrical continuity, that might help find the problem.

Yes. It is possible that the firmware on the programmer has somehow been corrupted but the bootloader is still be there, in which case you can access the bootloader and attempt a firmware upload by following the instructions in the user’s guide. I recommend trying this.

Yes. We bring all the ISP pins of the ATmega328p out to a standard 6-pin header. You can use any programmer that supports ISP and the ATmega328p.


After wasting a few hours of trying different computers etc I noticed the status led wasn’t even lit. I think it was lit during initial attempts. I then suspected the USB cable included with the programmer, which is of a “budget” type I would say.

I replaced it with a more solid USB mini cable with the typical ring filter, and the programmer immidiately came to life ! :sunglasses: So problem with programmer is solved.

BTW, I got excellent support from Pololu on this issue.