USB AVR Programmer Issues

I am running Win7 /x64 with AVR studio 4. I have an intermittent problem where, if I disconnect the programmer from the USB cable, then plug back in, I cannot re-connect to it from AVR studio. I select the Connect Dialog, and Platform=AVRISP, Port=Auto, repeatedly, and no response. I then close AVR Studio, and start from scratch. Still no response after multiple connection attempts. If I then close the app and disconnect the programmer, and wait a while ( 30+ minutes), I try again, and AVR studio connects to the programmer. This is very frustrating. Any clues for troubleshooting?

Also, I check that the Pololu USB AVR Programmer is shown on Device Manager.


I also have a problem like this, but only if I have the programming dialog or programmer selection dialog open when I connect the programmer. I think it has to do with how AVR Studio 4’s programming dialog handles the COM port. If you connect the programmer to USB with those dialogs closed completely, does it always work for you too?

- Ryan

No, it does not. I close the entire app, and then still get the error. Very frustrating.

Hi, just to be clear: it is important that no process has an open handle to the COM port at the moment you plug the programmer in to USB. AVR Studio’s “STK500 in ISP mode” dialog box keeps handle open to the COM port, so it must be closed at the time when you plug in the programmer.

Normally it is sufficient to unplug the programmer, then close all instances of that dialog box, then plug in the programmer and try again. Have you done this? Do you have some other instance of AVR Studio running in the background? Do you have any other programs open that might do things with serial ports?

If this doesn’t work for you, you may have to use a tool to see if some program is keeping a handle open to the COM pot when it shouldn’t be. I can help with that.