USB AVR programmer is not working

I’m probably doing something wrong. I have a USB tiny and was doing the programming using winAVR but wanted to be able to program the fuses and other things that a USB tiny doesn’t have access to. So I am new to programming from inside of AVR studio. But even when I try to use the USB AVR programmed inside of avrdude I still get strange errors. I tried different names for the programmer but nothing seems to work. I even tried using a different USB cable that I already had. Everything seems to be good in the Control panel Device manager. I have windows 7 64 bit version which was a problem with the USB tiny (I had to use it with my desktop windows XP machine.

I may have just figured it out. My power supply for the chip was set for 3.3 which was fine for running the chip but apparently not enough for the programmer. This is still a little preliminary as I haven’t actually updated the program yet but have been able to connect in avrdude.

Yes, AVRDUDE does produce “strange errors”. If you want to see more sensible errors, you should run the Pololu USB AVR Programmer Configuration Utility after a failed programming attempt. It can be found under your start menu.

Using Windows 7 64-bit is not a problem.

The default configuration of the programmer will not allow you to program an AVR that is being powered at 3.3 V. Changing the configuration could work but is not great because the programmer’s outputs (MOSI and SCK) will still be at 5 V. It’s best if you can power your AVR at 5 V during programming.