USB AVR Programmer 2.1 wont enter programming mode

I’ve been using the Pololu programmer for quite a while with no issues until recently. I just completed programming about 50 AVR Tiny13A chips in an 8-pin DIP package, on a board of my own desgin, with no issues. Then I began trying to program a newer version of the board, identical in all respects with the same processor, but surface mounted instead of DIP, and keep getting errors saying unable to enter the programming mode. Tried this with several different boards, including one that I built with nothing else on the board except the programming header, power connection, and 10K pullup on the reset line. Also tried my spare programmer with same result. It appears there’s something different between the DIP chips and the surface mount chips but I can’t imagine what or why. I have successfully programmed these surface mount chips in the past but for some reason now they’re no-go. Any suggestions on working around this would be appreciated.


If you have not already, I recommend going through the “Troubleshooting AVR programming issues” section of the AVR programmer v2 user’s guide.

If none of the suggestions there help, can you confirm whether are you still able to program the ICs in the 8-pin DIP packages that you have programmed before? Have you been able to ever program any of these new surface mount ICs, or is the error consistent?

- Patrick

Just to double check, I went back and reprogrammed one of the DIP chips and it worked fine. Same cable, same programmer. None of the surface mount chips will program. I tried four different ones from two separate batches that I built from. I built a test circuit board with nothing on it but the AVR chip, programming header, reset pull-up resistor (10K) and 5 volt power connection. Still no go. Twice cross checked the circuitry between the surface mount board and the DIP board - identical in all aspects except the physical placement of parts. Also tested two different surface mount chips - one a wide body and one a narrow body (both SOIC). I’m running out of ideas. Could there be something different in the factory configuration of these chips vs. the DIP chips? BTW, I’m working in the Codevision AVR environment if that makes any difference. This is the tool I’ve been using for over 10 years and haven’t had any issues with it.

We do not manufacturer ATtiny13A chips or use those chips in any of our products, so I could not tell you if there are differences between how they are made.

Did you go through the steps in the “Troubleshooting AVR programming issues” section of the user’s guide like I suggested? Can you post a screenshot of what the Pololu USB AVR Programmer v2 Configuration Utility software looks like after it fails to program one of the surface mount chips?

- Patrick