USB AVR programmer 2.1 help

Hi there Guys,

Sorry, if this is super obvious for others, but I’m stuck, so thought, it is better to ask :wink:

I have a 2.1 USB programmer and I’ve used it in the past successfully, yet, it was sitting a box for a long time.
I have now a new computer, an M1 Mini, and I just can’t get the unit working.
I’ve read that I have to update the firmware (I’m on 1.02), I’ve downloaded the firmware v1.08, yet, I’m stuck in how to update it?
According to the online resource, I have to push the smart bootloader button, yet, the unit on the picture is different, mine does not have any buttons - or I’m blind.

Could you please help me out?

Bump? :smiley:

After some investigation, it turned out that firmware 1.02 is the latest for my programmer.
Unfortunately, I still can’t get it to work, avrdude always reports me that

avrdude: opening programmer “avrispv2” on port “usb” failed

I’ve installed everything - I think, what could be wrong?

Still nothing unfortunately :sa:


Can you provide more details about what you are trying to do and what is happening? For example, what is the target device, how are you powering it, and how do the programmer’s LED behave when you try to upload a program with it? Some pictures of your physical connections and a video showing the LED behavior would be helpful. The forum does not allow users to post very large videos, but it does work well with videos linked from other sites (like YouTube or Vimeo).

Was the screenshot of the programming utility taken after attempting to upload a program? It is not showing any errors, but one immediate concern is that it is measuring only 704 mV from the target device, so it would probably be good to double check those connections or possibly reconsider how you are powering the device.

- Patrick

Hi Patrick,

Thank you very much for your reply.
I’m trying to program an Attiny84, on a “CVPal” board with the ISP port on the board.

I had built this board successfully, with this programmer, the only thing that changed is my computer - I had to reinstall all the software and such and I remember, I had the exact same issues and problems back then - sadly, I’m not doing this programming all the time so I just totally forget how it was solved.

As I wrote, I know that the programmer itself works, also, the circuit and boards works as well - USB cable is also the same.

When I connect the programmer only, I have a steady GREEN led and a blinking RED led.
Then, when I click on “Connect” in the Pololu monitor software, I have a blinking RED led and the GREEN blinks shortly and this the screen of it.
(Note, these are the “base” settings of the software, I’m just a total n00b, I left all the settings as they were.)

Then, this is the screen, after I plug the programmer cable to the board (ISP), leds on the programmer are the same, RED is blinking, GREEN is also blinking shortly.

These are the programming commands:

avrdude -V -p t84 -c stk500v2 -P usb -B 10 -e -u \
        -U efuse:w:0xff:m \
        -U hfuse:w:0xd6:m \
        -U lfuse:w:0xde:m \
        -U lock:w:0x2f:m
avrdude -V -p t84 -c stk500v2 -P usb -B 1 -U flash:w:cvpal.hex:i -U lock:w:0x2f:m

And these are the error messages from avrdude:

avrdude: "safemode" feature no longer supported
avrdude: opening programmer "stk500v2" on port "usb" failed

avrdude done.  Thank you.

avrdude: opening programmer "stk500v2" on port "usb" failed

avrdude done.  Thank you.

As you can see, I’m a total n00b, any help would be welcome.

Instead of -P usb on the avrdude command line, have you tried -P /dev/cu.usbmodem003109462 listed as the programming port in the GUI screenshot you shared?

As I mentioned in my previous post, the most obvious issue to address first is that it seems like the Attiny84 is not being powered appropriately since the Target VCC measured by the programmer is well bellow the level required for programming. The red LED blinking is also an indication that the target’s VCC reading is outside of the acceptable range. How are you powering your Attiny84? If you post some pictures showing your actual setup, I might be able to double check your connections.

If you have not programmed anything using your programmer in a while, then you might also consider reviewing our AVR Programmer v2 User’s Guide to refresh yourself on the procedures. It sounds like you are using AVRDUDE, so in particular, I recommend reviewing the “AVR programming using AVRDUDE” and the “Troubleshooting AVR programming issues” sections.

- Patrick

Adam, that worked, thank you very much!!!
Patrick - surely, I had to power the chip, I set the Pololu to give 5V to it, and it programmed like a charm!

Thank you very much for your help, I’ll save the settings and command for later for sure!!!