USB AVR Programmer (1300) Windows Vdd min. is zero

USB AVR Programmer (1300) seems to error when ever I try to perform any functions with communicating to the micro controller (ATTiny25). I’ve tested for continuity of all pins from the micro controller to the bottom of the AVR programmer. Vdd from of the programmer is connected to Vcc of the microcontroller. Shared grounds as well. I’ve tried powering the micro controller from a separate power supply as well as powering it from the VBus of the programmer.
On initial start up, the Green LED is solid and the yellow is blinking; so the device is recognized. I’m using AVR Studio (AVRISP). It opens the comm port and it passes a write/read of the ISP freq. However, any other attempt to read/write from/to the device; the RED LED is solid. Upon checking the error from the Pololu program utility, it states that Vdd minimum or range is outside of the allowed values. Same results using AVRDude too.
The part that puzzles me is that the GUI states that the last minimum Vdd is 0. I tested the voltage with a Multimedia, and it was 5.1 V (same as Vcc). I even connected it to an oscilloscope (with short and long volts/div), and there was not any voltage drop. I’ve tried three different microcontrollers - all with the same result. They do work on an older programmer I borrowed from a friend.

Any guidance would be greatly appreciated!

Could you try disconnecting the programmer from everything and then connecting it only to your PC? In this case, the programmer should be reading a low voltage on its Target VDD line, so the green USB LED should be solid, the yellow LED should be off, and the red LED should be slowly blinking. Then if you connect your microcontroller while it is powered, I would expect the LEDs to again blink as you described above.

Also, what is the VDD Max reported by the GUI after a programming failure?