USB 16-Servo Controller driver for x64

I’ve just bought the 16-Servo USB controller, however the driver you provide on your website does not work on Windows XP x64: when the device is found and I point Windows to the drivers directory it says it found no compatible driver for that device. I have a dual boot with an old plagued XP 32bits install and installed the driver successfully (the LEDs reacted when I typed some characters in Hyper Terminal), so the problem is not from the hardware or a download corruption.

I noticed the board has a SiLabs CP2102 chip and tried SiLabs’s VCP driver but it isn’t able to detect the device, just like your driver (didn’t try SiLabs driver on XP 32bits though).

Can you provide a 64bits driver for the controller ? I’m a software engineer and could easily compile it for you if you provide me the sources, either as open source or through a Non-Disclosure Agreement. Any help would be appreciated, I’m stuck with no possibility to use the controller (and going back to 32bits Windows is not an option).

Silicon Labs has been dragging their feet on drivers for some other platforms as well (although they already support Vista, oh great), but their Virtual Com Port driver (VCP) isn’t the only option.

Jim Remington pointed out (in this thread) information on generating your own driver here:

SILabs also offer a “USBXpress” development kit that claims to let you develop a direct interface with “No USB protocol or host device driver expertise.” This actually sounds to me like “you must be a software engineer to even think about making this work.”

I wouldn’t be surprised if these also turn out to be completely incompatible with 64 bit windows, but they might be worth a look for you.

If you do come up with something please let us know. My home computer is currently running 32 bit Windows on a 64 bit Athlon, and I’d like to make the switch at some point (or go back in time and save my money for a quad-core!).


Thanks a lot, you pointed me to the right place.

I used the driver generator wizard to create a new driver.

Wizard is there: …

Manual is there: … /an220.pdf

I used VendorID 10C4 and ProductID 803B. The newly generated driver worked on first try. I can publish the generated driver if some people need it.

I’m fine for now, not making the 64 bit jump any time soon, but thanks.

What are you planning to have your 16 USB controlled servos do?