Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Unable to reconnect to Wixel

I am trying to use the Wixel configuration utility to write an App to a Wixel. I have two Wixels, and the utility is able to read/write apps to the board without issue. When I try the same methods on the other Wixel, the utility says “unable to reconnect” and “unable to load image”. Has anybody experienced these issues before? Thank you.

Hello.

I moved your post to the “Wixel” section of the forum.

Without more information about what you have tried and what you are doing, it is hard to give any specific suggestions. However, you might try putting the problematic Wixel into bootloader mode and seeing if that fixes the problem. You can find instructions for doing that in the “Connecting Buttons and Starting the Bootloader” section of the Wixel user’s guide.

If that does not work, could you give us more information? For example, what all is the Wixel connected to? Did you already load a different App onto that Wixel, and if so, which one? What steps do you follow between plugging it into USB and seeing the error messages? Could you post a screenshot of the errors?

Brandon

Hi Brandon,

Thanks for your reply. Currently, I am trying to get the Wixel into bootloader mode by connecting3v3 to P2_2 and then connecting the USB. When I do this, the yellow light turns on solidly, but the Wixel does not show up in the Configuration Utility.

The only apps that I have loaded previously were the blinking LED app and wireless serial app.

Do you have any other suggestions for resolving this problem?

Thank you.

I should add that the Wixel is visible in the computer’s device list.

Thank you for the additional information. From the LED behavior, it sounds like it is going into bootloader mode. Could you post a picture of your computer’s device list showing the entry for the problematic Wixel? What operating system are you using?

Brandon

Hi Brandon,

Thanks for the reply. Here are some screenshots from Windows 10 device manager and the Wixel Configuration Utility. Please let me know if any other screenshots would be helpful. I’m using Windows 10, but have also tried Mac OS 10.15.4 and have not been able to connect with that OS either.

The device will show solid yellow LED with the bootloader methods mentioned above. However, it won’t show up in the Wixel Configuration Utility when the yellow light is solid. If I unplug the P2_2 and 3V3 wire, the USB LED turns solid green and the Wixel populates in the Configuration Utility. At that point I get the “operation timed out” error shown in the screenshot. I’ve also gotten a similar error includes “Unable to read image from Wixel” after “operation timed out”.

Thanks again for your help.

Picture4 Picture3 Picture2

Thank you for the additional information. Could you press the “Stop App” button in the Wixel Configuration Utility while looking closely at the entries for the Wixel in your Device Manager as well as monitoring the 3 LEDs on the board and report what you see? In the Device Manager, please look for any entries that might be the Wixel in the “Pololu USB Devices”, “Ports (COM & LPT)”, and “Other Devices” categories.

Then, could you redo the same test again but instead of using the “Stop App” button, short P2_2 to 3V3 while connecting the Wixel to USB?

Do you get different results in those two cases?

Brandon

Sure thing. When I press the stop app button, the configuration utility outputs:

" 16:03:52.809 : 5&3B489C26&0&1 : Stop App
Sending command to get Wixel into bootloader mode…
Waiting for Wixel to reconnect…
Timeout while waiting for Wixel to reconnect.
Operation timed out."

The Wixel is still visible in the device manager during that time. When I follow those procedures while shorting the P2_2 to 3V3, the wixel disappears from both the device manager and configuration utility.

Thanks.

Thanks for following up with those tests. It sounds like something is probably wrong with the bootloader. How long have you had the problematic Wixel and where did you get it from? Were you able to successfully program it before or has it always given you these errors?

Brandon

Thanks, Brandon. The Wixel is approximately 2 years old, I’m not sure where it was purchased from. It was successfully programmed up until about 2 weeks ago, when we started experiencing connectivity issues between it and another Wixel. I tried to reload the program, at which point we started experiencing these issues.

It sounds like something might have caused the Wixel’s bootloader to no longer work correctly. Unfortunately, I do not have any other suggestions for getting it working again; if the problem started with connectivity issues, it might just be that the hardware itself is now damaged in some way.

The Wixels are available at a discount right now through our 2020 Christmas Sale, so you might consider picking up a replacement.

Brandon