Unable to enter programming mode


I’m new to programming AVR microcontrollers and have some trouble connecting to the microcontroller(ATMEGA328).

I’ve got the Pololu USB AVR programmer and using ATMEL studio 6. When i’m trying to read device signature i’m prompted with “Unable to enter programming mode.”

My config utility window:

And the window from studio 6:

I’ve connected the wires according to the datasheet:

GND => pin8
MOSI => pin17
VDD => pin7
RST => pin1
SCK => pin19
MISO => pin18

Layout in datasheet:

I’ve tested these connections with a multimeter, no shorts or broken connections.

I’ve tried the troubleshoot article at pololu’s homepage, with no success. Hoping for suggestions, i’m a bit stuck :frowning:

The microprocessor was pre-loaded from my supplier with a bootloader UNO, arduino? Is this a problem, I just want to program in C++ from studio 6.

I have a green light on the programmer a permanent red and a flashing yellow. Before trying to program where was no red light.

Kind regards
Bjarne Jensen

Hello, Bjarne.

Thank you for providing so many details! I am sorry you are having problems programming with your AVR programmer. The preloaded Arduino bootloader in the ATmega328 should not be an issue. I suspect there might be a wiring issue. What other components do you have connected to the ATmega328? Could you post pictures of your setup?

- Jeremy

Thanks for replying. I’ve now connected another avr (attiny13) to the programmer and this works just fine :slight_smile: I’m glad to hear that pre-loaded bootloaders isn’t a problem :slight_smile:

I’ve checked my wiring for ATmega328 over and over again without finding any flaws. I haven’t connected anything but the wires for the programmer and a 5V DC power source. All mounted on a breadboard. Maybe i’ll try one more time before I discard it - it’s brand new but I guess s*** happens :slight_smile:

I’m glad to hear that it isn’t a generel problem with the programmer and ATmega328 :slight_smile:

If you post pictures of your setup, I could double check your wiring.

- Jeremy

Thanks for replying. I’ve tried to connect the ATmega328 again - unfortunately with same result

I do not see anything obviously wrong from the picture. I suggest trying a new ATmega328 and see if you have the same problem.

- Jeremy

Hi there, was it solved by changing chip? Because I’m having the same problem.


Why do you think you have the same problem? Do you get the same error from the Pololu USB AVR Programmer Configuration Utility and Atmel Studio as the original poster? Could you post pictures of your setup?

- Jeremy

Well… My brother solved it by the RT*M method. :blush: It was related to the frequency settings, he keept lowering it until the device was found. The atmel environment feels as tricky as the assembler language. :wink:

Thanks for letting us know. I am glad you got it working. When programming AVRs with our programmer, the ISP Clock frequency should be less than 1/4 of the frequency of the device.