UM7-LT Serial Connection Issues

Hello,
Our team is trying to connect a UM7-LT IMU to a raspberry pi via the GPIO TX and RX pins using UART.
This very well could be a raspberry pi problem, but we have tried nearly every suggestion that we have found online and have not been able to get it work on the raspberry pi side of things, so we have reason to believe it is something with the IMU.

Upon connecting, the output in the console is a bunch of gibberish text.
We have verified that the TX and RX pins are connected correctly, 3.3v supply is being used, and a proper baud rate (115200) is being used.
We have tried adjusting the baud rates from 9600 - 115200, changing the language settings on the raspberry pi, and checking for inverted voltages.

Reading the data sheets, we are expecting the data to be .nmea strings, which should be outputting normally to the console. But the output is still garbage.
Raspberry pi is linux, so we cant install RedShift Labs software to test if it is working that way.
(I will attach a screenshot of the output in the terminal)

Any and all suggestions would be appreciated.

Thanks,

I am sorry you are having trouble communicating with your UM7-LT. If you are using a Raspberry Pi 3 or Raspberry Pi Zero W, by default the Bluetooth modem is enabled, which prevents communication with the serial interface. So, you might try disabling Bluetooth. If that does not work, and you are sure your connections are correct (e.g. TX on one board should connect to RX on the other and there is a common ground), I recommend contacting the manufacturer, Redshift Labs.

-Jon

Jon,

Thank you for your response.
We have disabled bluetooth in the config file and have triple checked TX-RX connections and it is connected to the GPIO ground pin.
I will contact RedShift and update this thread if/when I find a solution.

Thank you for your time,

  • Connor