U3V12F9 and li-po battery

I have used this step-up 9v regulator with a 7.4v LiPo battery for some time with no problems for driving the motors on my small robot… However last night I was using the #799 adjustable regulator and it burst into flame for no apparent reason. At the time it was connected to my SV-328 board but NOT running the motors. I have attached photos showing the burned board and a side view showing that nothing was touching the board.

I have shorted the output of these boards before and sure, it kills the board, but with no flames or drama. I’m convinced that this was a failure of some kind.

I was concerned that the LiPo itself might catch fire if it was shorted but it didn’t even get warm and still showed the same voltage as previously.


I have moved your post to a new thread.

I am sorry about your regulator. Did you set the output voltage on the regulator before connecting it to your setup? If so, how did you set it and what did you set it to? Did you use a multimeter when you were setting it?

- Grant

Hi Grant,

I set the voltage with a DVM as close to 9v as I could, it was somewhere around 9.1v. Also, everything was working fine and the robot had been successfully line-following using this power supply earlier in the evening.


In an earlier post, you mentioned swapping the 9V Step-Up Voltage Regulator U3V12F9 out for the adjustable boost regulator. When you swapped regulators, did you also change your setup to match the different pin layout? The location of VIN and VOUT are swapped between the two boards, and looks like in your picture that you have two header pins for input power next to VOUT and GND.

- Grant

No, I didn’t swap out the 9v regulator for the adjustable one. In a previous design I used the 9v regulator with a 7.4v LiPo, and I was just telling the poster that this setup worked OK for me. The design using the adjustable regulator is a completely new one and I built a completely new circuit board to use it.

The new circuit board worked fine for a couple of hours. I ran my line follower robot OK with it and it drove the motors OK. Later I was running a sensor test reading out the sensor values to the SV-328 LCD, when the regulator self-ignited. The motors were not running.

The circuit board takes a 7.4v LiPo input and gives an adjustable output which I move around between 9v and 12v. I need to monitor the LiPo input voltage because they fail if you run them down too far, so there is a 10K/33K resistor divider network at the input to give me a lower voltage which goes to ADC7 for monitoring purposes. These are the two resistors you can see under the regulator board, and this is the reason for the three header pins at the input side of the circuit


You mentioned adjusting the output voltage between 9V and 12V. Were you adjusting the output voltage of the regulator around the time it caught fire? If you adjusted it while you had the 7.4V LiPo (which can be above 8V when charged) connected and accidentally turned the pot too far, causing the output voltage to be less than the input voltage for a short period of time, that could have damaged it. There is a warning about not letting the regulator’s output be less than its input on its product page.

- Grant

No, I was not adjusting the voltage when the regulator caught fire. As stated previously I was running a sensor test reading out the sensor values to the SV-328 LCD.

Maybe we should take this off line. Can you pm me please? Your pm appears to be disabled.


At this point, I am not sure what caused the regulator to fail. If you contact us directly at support@pololu.com with your order information and reference this forum post, I might be able to get you a discount on a replacement regulator.

- Grant