Pololu Robotics & Electronics
Menu
My account Comments or questions? About Pololu Contact Ordering information Distributors

Pololu Forum

Trouble with A-Star 32U4 Mini finding Mac port

Hi,
I have been using the A-Star 32U4 Mini without issue on my Mac laptop running Mojave for months. I use the Arduino IDE. Today I connected the laptop to the board after starting an upload and I seem to have messed things up… I’m getting the dreaded Connecting to programmer: .avrdude: butterfly_recv(): programmer is not responding error message. The port that the IDE is using is /dev/cu.Bluetooth-Incoming-Port.

I tried running the Blink example on an A-Star 32U4 Micro with a different USB cable and I noticed that an additional port was identified by the Mac and the IDE, namely /dev/cu.usbmodem14201. The sketch uploaded fine. When I re-connect the USB cable to the Mini the /dev/cu.usbmodem14201 does not show up on the Mac.

Any ideas how to fix this problem?

Thanks Tom

Looks like I jumped the gun. After reading the fine manual I tried disconnecting everything from the board and pressing reset twice (within 750 ms) after starting the upload and it cleared things up. The laptop now sees the virtual USB device.

Tom

1 Like