Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

Trouble Programming the 3pi


I think I did the same trick? I wonder if I damaged the 3PI. The original demo program to teach us to build, complile and deploy may have loaded. There was a “B” return inidcator on LCD so I pushed that… but I never heard tone or LED’s etc… I powered down 3pi while connected to avr. now if I disconnect from avr and restart (power) i get blue LEDS on bottom and faint blocks on top row of LCD. I have tried to re build demo solution, debug and deploy… Lights on avr flickr yellow and red… there are no errors in output… but no response on 3pi. Can I go back to program shipped from factory? where is it located? thx !


I have downloaded and compiled and tried to load the factory demo code. I got all errors and warnings eliminated, and build is successful. Continue yields a single line in the back agent out put:
01 03 11 245: tcf Using tools from
That’s it. The light on the AVR programmer board two greens at usb cord connection, and one flashing yellow at ribbon cable connector. Does an upload take a long time?



I moved your post to a new thread. We are currently aware of a bug that is causing programming issues when using Atmel Studio with our programmer, and we are working on reporting the bug. Could you try programming your 3pi using the following workaround?

  1. Compile your program using “F7”.
  2. Go to Tools -> Device Programing.
  3. Select “STK500” under the “Tool” menu. The “Device” and “Interface” should then show ATmega328P and ISP, respectively.
  4. Click “Apply”.
  5. Go to the “Memories” section and click the “Program” button under the “Flash” menu.

If this workaround does not work, could you tell me more about your setup? Do you have any additional things connected to your 3pi? When was the last time the batteries were charged or replaced?

- Jeremy

Failed to Set up Tool (No Context ID Returned) with AVR Prog
Can't program 3pi