Timeout error connecting CHR-UM6 with PC over USB

Hi, I am trying to use a Pololu CHR-UM6 for a Uni project and am having trouble getting the data from the sensor.
It’s entirely possible I’m just making a stupid mistake as my electronics knowledge isn’t too good… (I connected the Rx wire to the Rx pin when I was soldering the wires to a RS232 connector).


  1. I soldered the Rx and Tx wires to their appropriate pins (eventually) on an RS232 connector.
  2. Plugged that into the parallax USBtoSER adapter.
  3. Connected the USB cable to my computer and the GND and V wires to a desk power supply.
  4. CHR-UM6 PWR light turned on, as well as the connection and (flashing) data light on the adapter.
  5. Opened the CHR Serial Interface v3.0.9 (which I got from the download section of the sensor page) (I also tried opening the program before connecting the sensor).
  6. Pressed the connect button, which became greyed out.
  7. Received the error message "Error: Timeout while communicating with sensor.[/ol]
    This is my problem, obviously. From what I read here, it might be the USB to SER adapter I’m using? Is there some other stupid mistake I’m making?

Thanks for your help.


You are correct; the USB to RS-232 adapter you are using is not appropriate to use with the UM6. It only accepts TTL serial signals. You should try using a USB-to-TTL serial adapter instead.

Also, please note that since RS-232 signals can be ±15V, so connecting the TX pin from the adapter to the UM6 might damage the UM6.


Hi Derrill,
Thanks for your quick reply. So using the adapter you linked is the best solution? I just connect all four of the wires from the UM6 to that adapter and it will connect properly with my computer and work safely?


Our USB-to-TTL serial adapter should work fine between the UM6 and a computer. You can see how to connect those wires in the “Using the UM6 Without the Serial Breakout Board” section of the “Getting Started with the UM6 Orientation Sensor” application note. If you still have issues after using a serial adapter like that, please post again, and we can look further into those issues.



I am having similar connectivity issues with my CHR-UM6, but I am using a TTL to RS-232 converter breakout board…

I’ve wired the VCC and ground pins of the CHR-UM6 to the 5.0V regulated output of an mbed microcontroller and its ground. The TX and RX pins of the sensor are connected to the RX and the TX pins respectively on an RS-232 shifter (sorry, not a pololu product… support.robotis.com/en/product/a … manual.htm) adapter (with the switch set for RS-232) to connect the serial RS-232 to a USB hub.

The power light comes on, and the TX LED on my RS-232 shifter flashes rapidly, but when I start up and run the CHR Serial Interface program, I get a timeout error. I’ve tried using PuTTY to access the serial more directly, but it is to no avail. The USB/Serial adapter I’m using also registers on my device manager, so the drivers are installed.

I’d really appreciate any help on this you can give. This is the only forum I found where some one has experienced this type of error! I feel like there must be something obvious I’m over looking… I might buy your USB to Serial adapter (pololu.com/product/1308) if it would work any better than the setup I have now!

Thanks for your help,

Hello, Chris.

I am sorry you are having trouble connecting to your UM6. From your description, I am not entirely sure how you are connecting everything. If you post a schematic that shows how you have everything connected, I would be happy to take a look at it.

Alternatively, you might consider contacting the manufacturer of that board, CH Robotics, by posting on their forum, which is the best place to get support for their products.


Thanks for taking the time to reply Jon!!

As I was playing around with the UM6 more the next day, I found a code that used my mbed to read the data from the UM6 to the USB serial output. After a lot of tinkering, I finally got it to send data! I later found a Pololu USB to serial adapter in my lab, and it worked even better. I’ve thus concluded it was an issue with the USB2Dynamixel adapter I was using.

Thanks for your reply!!

I am glad you figured it out; thanks for letting us know what the issue was!


Hello it’s me again!
I finally got a USB-UART adapter, but after connecting it, it still times out when I try to connect! Am I doing something stupid again, or is there a bigger problem?
Here’s the sensor:

Serial adapter:

Adapter page: https://www.silabs.com/products/interface/usbtouart/Pages/usb-to-uart-bridge.aspx
I installed the latest driver from their page and installed it. Shouldn’t this work using the CHR Serial Interface as it is? Or do I need to do something else?
I also get a timeout error when trying to connect and get data using MATLAB.
Also get the same error when connecting to 3V3 instead of 5V on the adapter.
The LED on both the AHRS and adapter light up and stay lit solidly; never flashing.


It looks like you might have switched your RX and TX connections. RX from the USB-to-serial adapter should connect to TX on the UM6, and TX on the adapter should connect to RX on the UM6. Table 6. of the “UM6 Ultra-Miniature Orientation Sensor Datasheet” (which you can find under the Resources tab of the UM6’s product page) makes it seem like the white wire on your UM6 is RX and the yellow wire on your UM6 is TX. If you still get a timeout error after switching those connections, I recommend doing a loopback test. You can do a loopback test by connecting the USB-to-serial adapter’s RX pin to its own TX pin, disconnecting the rest of your system, and sending something with a terminal program to see if it gets echoed back. Also, if things are still not working, can you tell me how much current your US-to-serial adapter can supply?


Hi Jon,
You know, when I soldered wires into the 232 adapter I made the same mistake. Made the same mistake again, haha. I’m actually glad it was a stupid mistake like this instead of something more complicated.
Connected with the CHRobotics Program and it works! Finally, haha. Now just to get the data with MATLAB…
Thanks for all your help!