Ticcmd arguments and errors


I am running my stepper motors using ticcmd. My first error is that sometimes I get the error:

“Error - There was an error setting the target position. Control transfer failed. The request was invalid or there was an I/O problem. Error code 32” when I run

ticcmd -d 00357615 --exit-safe-start --position 1000

When I unplug the usb connector to the driver and plug it back it works.

My second error is that when I run the command:

ticcmd -d 00357615 --exit-safe-start --position-relative Num

where Num is any number used between 1000-5000, the stepper motor turns the same amount. Only when Num is less than 1000 does it go the correct amount. Is there maximum Num? Also what is the difference between --position and --position-relative?’

Third error is when I run:

ticcmd -d 00357615 --exit-safe-start --home rev OR
ticcmd -d 00357615 --exit-safe-start --home fwd

the stepper motor doesn’t move. I tried using the quotations. No differen

Fourth question. The argument --target is mentioned as an example in the tic driver pdf manual but does not show up in the parameter list when I run ticcmd.


1.That error might be coming from electrical noise that’s causing problems with the USB communication. You might try using a different USB cable (possibly one with ferrite beads at both ends might help) or using a powered USB hub.

  1. It sounds like you are probably getting a command timeout error. By default, the Tic’s “Command timeout” error will happen if it does not receive certain commands periodically. You can run ticcmd --reset-command-timeout every second to get around this; alternatively, you can change the timeout length (or disable it entirely) under the “Input and motor settings” tab of the Tic Control Center.

  2. Due to the way the homing command is currently handled, using a short delay (something like 20ms) between sending --exit-safe-start and --home should fix the problem.

  3. That was a typo in the user’s guide; thank you for pointing it out! When it mentions “–target” it is referring to “–position”. We have updated the web version to fix that.


Hi Brandon thanks for the answer,

  1. I doubt the problem is electrical noise because I purchased the usb cable from your website which was recommended for the tic driver.

  2. What is the difference between --position-relative and position?


Also I tested out the homing function and it works but does it only work at one speed or can it be changed?


Our USB cables do not have ferrite beads at either end, and can still be susceptible to noise like any other. That error looks like a system level error (not one from our drivers or software), and seems to indicate that there is a problem with the communication signals, which is usually caused by electrical noise. You could try different USB ports on your computer or making sure your USB cable isn’t running near high power wires (like from your power supply or stepper motor), but if the problem persists and is caused by noise, it can be improved by using a powered USB hub or a USB cable with ferrite beads like I mentioned before.

The --position-relative option sets the position value relative to the current position. For example, every time you send --position-relative 100 it will move forward 100 steps from where it currently is. In comparison, the ‘–position’ option specifies a absolute position. So, if you send --position 100 it will move to the position 100. If you send it again, it will not move because it is already at the commanded position.

The homing speed (in either direction) can be configured in the “Advanced settings” tab of the Tic Control Center. You can find more information about this in the “Setting up limit switches and homing” section of the Tic user’s guide, under the “Setting up homing” heading.