Pololu Robotics & Electronics
My account Comments or questions? About Pololu Contact Ordering information Distributors

The robot has become non-programmable


Hello,I have a problem with the 3pi robot.My knowledge of English is not great,but I hope you understand the content of my letter. I installed it the demo program from the folder exemple and all was well.I have tried all of these programs(following the line,and others) all worked until the moment I pulled in avr studio and then on my robot installed something and then I can’t get it reprogrammed.I tried to reinstall the driver,avr studio,even tried on another PC but it didn’t help.When you turn the 3pi just burn the diodes and everything.And the display boxes.Please help me to solve this problem.



How old is your 3pi? If you are not sure, can you please post the serial number of the 3pi? The serial number tag can be found on the bottom of the 3pi board.

Which version of AVR Studio and AVR programmer are you using to program the 3pi? Can you try changing out the current batteries with fresh batteries and see if that changes anything?

- Amanda


I do not understand this:

Did you mess with the fuse or lock bits? Did you get an error when you try to reprogram it, or does it fail silently. I recommend programming on Linux, because Windows and OSX have destroyed lots of my things.