TCF (TCF command: Tool:connect failed.)

Just joined
I am using for the first time Studio 6 and the USB Programmer. With no success I might add.
I have followed the guides and come up with the error in the subject.
My target is an Arduino Uno which keeps throwing up ’ not in sync error’ via avrdude.
I am hoping that going the Pololu route will prove successful.
Can anybody help me out.



We can help you out with that. Have you seen the tips and information in the “Troubleshooting” section of the Pololu USB AVR Programmer User’s Guide? That section covers a lot of the common problems people encounter. It sounds like your Atmel Studio is failing to connect to the programmer, so you should focus on the “If the computer fails to connect to the programmer:” subsection.

If that doesn’t help, could you provide me more details about what you are doing? What precise version of Atmel Studio do you have? What COM ports do you see in the Device Manager and what do you see if you click “View > Available Atmel Tools” in Atmel Studio? Is there a more detailed error message in the Output pane of Atmel Studio? What is your procedure for programming?


Hi David
Sorry that it has been a while to respond. I have gone throught the whole process from start to finish. New software all round and followed the tutorial in the guide (Section 3). Still no success, so I will give you all the information I have.
The latest error being:
Unable to enter programming mode. The read device id indicates that the connected device is an ATmega328.
Please verify device selection.

You asked for some information so I shall answer your questions

Running Window 7 Home Premium Edition
Atmel Studio 6.1 Update 2, Build 2730, Service Patch 1
Com ports seen in Device Manager - Pololu USB AVR Programmer Programming Port (Com7)
- Pololu USB AVR Programmer TTL Serial Port (Com6)
View Available Tools Simulator Connected
STK500 (Com7) Program only Connected
What is my procedure for programming ? If I can successfully use Studio 6 and use the Atduino sketches that would be great.
I have never programmed in C or C++. I am desperate to get round the ’ not in sync error’ via Arduino IDE and Avrdude.
I have tried with 5 Atmega 328Ps and still get the same error. Is it the Arduino IDE, Avrdude? I did manage in the early days to load the blink sketch before the error presented itself. If I plug that particular eeprom into the Uno board it runs. So the board doesn’t appear to be the problem - I think - flashing LEDs seems to be the norm working or not.

The Pololu board when plugged into the PC has a steady GREEN light and also a flashing YELLOW next to the 6 pin header.
The UNO is powered from a separate supply has a GREEN power light ON, PIN 13 flashing.

I have also tried -
CP2102 (Hobbytroniks)
CP2103 Breakout Board (Sparkfun)
TinyUSB (Adafruit)

Just going round in circles. I should be able to something with the kit, I keep following all the guidance.
Hopeyou can help



It would help me understand your situation better if you could give more details about this error message:

What piece of software gave you the error message? What buttons did you click to get that error message? What target AVR chip did you specify in the software and where did you specify it? It would help if you could focus on one particular setup that you think should work and tell me all of the details about it.

The error message is telling you that the detected AVR is an ATmega328 rather than an ATmega328p. Have you carefully examined the chips to see what kind they are?